Opened 11 years ago

Closed 11 years ago

#3523 closed Bug (fixed)

Original .torrent files renamed .added and do not resume on daemon restart

Reported by: TheBigYahi Owned by:
Priority: Normal Milestone: None Set
Component: Daemon Version: 2.04+
Severity: Normal Keywords:
Cc:

Description

On restarting transmission-daemon, no previously active torrents are present. I believe this is because whenever a .torrent file is added, it is immediately renamed to "filename.torrent.added". It appears that the watch directory doesn't automatically add .added files on restart. This occurs when adding by WebUI, transmission-remote, and also saving the file into the watch directory.

I verified this by stopping transmission-daemon, renaming the .added files to .torrent and restarting transmission-daemon. On restart the files are immediately renamed .torrent.added and the torrents restart like they should.

Also, a duplicate .torrent.added file is created with a bunch of hex characters between filename and .torrent.added.

Change History (1)

comment:1 Changed 11 years ago by TheBigYahi

  • Resolution set to fixed
  • Status changed from new to closed

Turns out the problem is that sometime in the last two or so months the daemon has stopped liking the Watch directory to be the same as the Torrent directory. I created a separate watch folder and the behavior is now as expected.

Note: See TracTickets for help on using tickets.