Opened 11 years ago

Closed 11 years ago

Last modified 11 years ago

#3532 closed Enhancement (duplicate)

Per-group Speed Limit rules

Reported by: tcn33 Owned by:
Priority: Normal Milestone: None Set
Component: Transmission Version: 2.04
Severity: Normal Keywords:
Cc:

Description

I'd like to request per-group application of Speed Limit as discussed here: https://forum.transmissionbt.com/viewtopic.php?f=5&t=7844

This would allow for user-customizable application of automatic bandwidth limiting. For users with peak/offpeak download/upload quotas this would be particularly useful to ensure that critical torrents are downloaded immediately and lower-priority torrents left for offpeak hours.

Note this is not a dupe of 844/757 as this is relating to the global Speed Limit rather than manually setting speed limits per torrent/group.

Change History (5)

comment:1 Changed 11 years ago by anotherspot

This would be a fantastic feature - would need to have both speed limiting and time settings per group.

Interface would probably need to incorporate a global group where the settings would incorporate the current bandwidth/time section and maybe some of the management section of the transfers preference.

comment:2 Changed 11 years ago by livings124

  • Resolution set to duplicate
  • Status changed from new to closed

This appears to be a duplicate of #1541

comment:3 Changed 11 years ago by tcn33

  • Resolution duplicate deleted
  • Status changed from closed to reopened

Reopened as I don't believe this is a dupe of #1541 - that ticket deals with speed settings per group, whereas this ticket deals with the time-based Speed Limit feature.

To clarify, the proposed functionality would not alter or replace the existing Speed Limit function - this would still be the same as currently implemented in Preferences > Bandwidth. The new functionality would instead be a per-group setting for whether the Speed Limit applies to that group.

Sample text (in Preferences > Groups):

[ ] Ignore Speed Limit for this group
When enabled, Speed Limit will be overridden for transfers in this group

This allows for specific transfers to be assigned to a group which allows peak downloading, while saving others for automatic off-peak downloading.

Merely altering the speed settings for a group to prevent peak downloading would mean that the download would never take place unless manually changed to a different group or the group speed settings were changed.

Last edited 11 years ago by tcn33 (previous) (diff)

comment:4 follow-up: Changed 11 years ago by livings124

  • Resolution set to duplicate
  • Status changed from reopened to closed

The linked ticket discusses setting specific speeds per group. Setting an "ignore speed limit" per group feels highly related. If anything, I can picture the specific speed setting going in over this much more obscure request for ignoring limits for a group. This isn't an exactly duplicate of that ticket, but it's close enough.

comment:5 in reply to: ↑ 4 Changed 11 years ago by tcn33

Replying to livings124:

If anything, I can picture the specific speed setting going in over this much more obscure request for ignoring limits for a group.

If it seems obscure to you then you probably do not have a quota limit and/or peak/offpeak quota limits :)

Regardless, setting a blanket speed setting that never changes until you manually change it is very different from setting a limit that is applied and removed based on time of day. If there's no difference (or if the two are "highly related") then why do we have Speed Limit in the first place?

Appreciate you taking the time to look at it - I've posted in the forums to see if I can drum up some more support for the idea.

Last edited 11 years ago by tcn33 (previous) (diff)
Note: See TracTickets for help on using tickets.