Opened 11 years ago

Closed 11 years ago

#3533 closed Bug (duplicate)

pausing one torrent pauses the rest

Reported by: vvl Owned by: charles
Priority: Normal Milestone: None Set
Component: libtransmission Version: 2.04
Severity: Normal Keywords: pausing
Cc:

Description

If I have several torrents running and I pause the last one, the download rate of the active torrents go to 0. Am not sure if it's the GUI that's "lying" or if the torrents are actually paused. At least they're not greyed out.

I can not replicate this 100% of the time, but every time it happens it has been while pausing the last torrent.

Sorry for the scarce information, will try to triage a bit more when I have time.

Change History (6)

comment:1 Changed 11 years ago by livings124

  • Component changed from Mac Client to libtransmission
  • Owner changed from livings124 to charles

comment:2 Changed 11 years ago by charles

vvl, did you ever get more time to triage this ticket?

comment:3 Changed 11 years ago by gn0s1s

Happens here as well, intermittently. I just paused all my torrents except one (to give it more elbowroom) and its transfer rate dropped to 0. Starting and stopping that torrent has no effect, it's like it's stuck, shows some peers connected but doesn't transfer. Then suddenly, after about a minute or two, it seems like the torrent "resets". It shows 0 of 0 peers and starts gathering peers again, and starts picking up speed, albeit slowly.

comment:4 Changed 11 years ago by charles

Is this still an issue in Transmission 2.12? I can't reproduce this problem.

comment:5 Changed 11 years ago by Timotees

Seems to be still an issue in 2.13. It doesn't happen all the time, that's the weird thing about it. Got 5 torrents running, pause 1, the others go to 0 kb/s . Then when I try to restart one of them, transmission freezes.

comment:6 Changed 11 years ago by charles

  • Resolution set to duplicate
  • Status changed from new to closed

Ahhh, I see what's going on. When you stop a downloading all its files are closed, so the OS flushes all of its cached data to disk. This currently blocks the libtransmission thread.

Closing this as a duplicate of ticket #1753. Thanks for reporting this.

Note: See TracTickets for help on using tickets.