Opened 11 years ago

Closed 11 years ago

Last modified 11 years ago

#3543 closed Bug (fixed)

Wrong link in the about window

Reported by: snoopydas Owned by: charles
Priority: Low Milestone: 2.10
Component: GTK+ Client Version: 2.04
Severity: Normal Keywords:
Cc:

Description

Transmission 2.04 - gtk+ client

In the about windows when I click to the link that point to the transmission website I obtaing this error

Could not find "/home/myuser/http:/www.transmissionbt.com/".

While I guess the right string should be "http://www.transmissionbt.com/".

I attached a screenshot just as evidence...

Thanks Snoopydas from Italy

Attachments (1)

Screenshot.png (91.2 KB) - added by snoopydas 11 years ago.
http link error in the about window

Download all attachments as: .zip

Change History (11)

Changed 11 years ago by snoopydas

http link error in the about window

comment:1 Changed 11 years ago by snoopydas

I discovered also that if I click on the http link with dx mouse button , choose the option "copy link address" and paste the result e.g. in any text editor or browser... the http link is correct!..

Snoopydas

comment:2 Changed 11 years ago by charles

What versions of glib2 and gtk2 do you have installed?

comment:3 Changed 11 years ago by snoopydas

Hi, here some details :

GTK+ 2.20.1 / GLib 2.24.2 (Gnome 2.30.2 GnomeSlackbuild?)

Distribution: Slack13.1

Regards Snoopydas

comment:4 Changed 11 years ago by charles

I'm not able to reproduce this error in 1.93 or 2.04. I think this is either an issue with gtk/utils.c's gtr_open_file() function, or a glib configuration error on your system. I don't have any debugging messages coded into gtr_open_file() unfortunately.

snoopydas, if I were to add debugging statements to the nightly tarballs, would you be able to make a new build from that tarball for your Slack machine to test?

comment:5 Changed 11 years ago by snoopydas

Regarding to build a nightly version... no problem, just let me known when available ...but I'll check on the transmission donwnload web page :)

In the meantime I did some other test... if can be useful :

for my needs, I also have a virtual Slack13.1 running on a virtualbox session but always with GSB 2.30.2 installed.

This is a standard installation : Slack 13.1 + GSB 2.30.2 (Gtk 2.20.1 / Glib 2.24.1 and Transmission 1.93) where I use to install only updates available from slack repository

Well, on that VM ..every things work fine : the default web browser is correctly opened and point to the transmission home page when you click on the http link in the about window...

Then I tried to downgrade GLIB2 and Transmission to the standard version, as the VM, on real work machine... but issue is still present, same strange error message ... arghh!!.. Thanks for your effort to solve this little issue :-))))

Cheers, Andrea (aka Snoopydas)

comment:6 Changed 11 years ago by charles

Andrea, could you please give build >= r11253 a try?

The nightly tarballs are @ https://build.transmissionbt.com/job/trunk-linux/

comment:7 Changed 11 years ago by snoopydas

Ok compiled and installed the nigtly build ver. r11253... and I'm happy to tell you that now the http links in the about window is OK.. just click on the link and the web browser open the Transmission home page.. :-)

I tried also to verify the option "Open link" that appear in the menu clicking with dx mouse button on the link itself, and it works too. The other option "Copy link address" works fine as before..

Andrea

comment:8 Changed 11 years ago by charles

  • Keywords backport-2.0x added; about windows removed
  • Milestone changed from None Set to 2.10
  • Status changed from new to assigned

comment:9 Changed 11 years ago by charles

  • Resolution set to fixed
  • Status changed from assigned to closed

Fixed in r11253

Thanks for testing the fix :)

comment:10 Changed 11 years ago by charles

  • Keywords backport-2.0x removed
Note: See TracTickets for help on using tickets.