Opened 11 years ago

Closed 11 years ago

Last modified 11 years ago

#3554 closed Bug (fixed)

Alternate speed (turtle) button does not update when toggled via RPC

Reported by: joxl Owned by: charles
Priority: Normal Milestone: 2.10
Component: GTK+ Client Version: 1.93
Severity: Normal Keywords:
Cc:

Description

  • Launch Transmission (GTK gui).
  • If there are no active torrents, start one (or more).
  • Enable alternate speed (turtle button).
  • Observe; confirm that the up/download rates are indeed limited to alt-speed, and that the turtle button shows the correct state.
  • Switch to your favorite terminal and execute:
$ transmission-remote --no-alt-speed
localhost:xxxx responded: "success"

BUG: Observe; up/down rates have resumed to unlimited, but the turtle button still shows alternate (slow) state.

EXPECTED: Turtle button immediately changes to match up/download speed state.

Also, the same thing happens (button state doesn't change) when you switch it back the other way:

$ transmission-remote --alt-speed
localhost:xxxx responded: "success"

Transmission version:

$ transmission --version
Transmission 1.93 (10621)
$ transmission-remote --version
Transmission 1.93 (10621)

System info:
OS: Linux [Ubuntu 10.04 (lucid)]
Kernel: 2.6.32-24-generic
GNOME: 2.30.2

Other notes:
This behavior only appeared earlier this year when the Ubuntu repositories pushed a newer version (sorry for the late report). I can't remember exactly which version it surfaced on, but I'm almost positive I first noticed it when I upgraded my OS from 9.10 --> 10.04. Checking my dpkg logs it looks like that would have been when the Ubuntu repositories upgraded Transmission from 1.75 --> 1.92 (I upgraded a few days late: 2010-05-03).

$ zgrep -h 'upgrade transmission-gtk' /var/log/dpkg.log* | sort
2009-10-31 09:00:35 upgrade transmission-gtk 1.34-0ubuntu2.2 1.51-0ubuntu3
2009-11-02 05:23:22 upgrade transmission-gtk 1.51-0ubuntu3 1.75-0ubuntu2
2010-01-15 17:00:12 upgrade transmission-gtk 1.75-0ubuntu2 1.75-0ubuntu2.2
2010-05-03 05:45:07 upgrade transmission-gtk 1.75-0ubuntu2.2 1.92-0ubuntu2
2010-05-05 22:32:30 upgrade transmission-gtk 1.92-0ubuntu2 1.92-0ubuntu2.1
2010-06-30 18:00:32 upgrade transmission-gtk 1.92-0ubuntu2.1 1.93-0ubuntu0.10.04.1

Finally:
As your "How to Report a Bug" rules go: "2. Test out a nightly build and see if the problem's already been fixed." I decided to give it a shot on the latest version. I recently (as in "just now") manually upgraded to the latest version available via. Ubuntu repositories (had to manually add the URL to my sources list to get it :). Sorry, it's not exactly a "nightly build", but I'm too lazy to compile from src.

I tried the above process and can still reproduce the issue on my current (new) version: Transmission 2.04 (11151)

Now I'm left with the problem of deciding which version to open this ticket under. I will leave it at 1.93 since that is what I was using when I started typing this post!

I hope this was helpful.

Change History (4)

comment:1 Changed 11 years ago by joxl

BTW, ticket 2907 (#2907) is the closest thing I could find to this issue. It doesn't describe my problem, but I thought I'd mention it in case it is related.

comment:2 Changed 11 years ago by charles

  • Milestone changed from None Set to 2.10
  • Status changed from new to assigned

comment:3 Changed 11 years ago by charles

  • Resolution set to fixed
  • Status changed from assigned to closed
  • Summary changed from Alternate speed (turtle) button does not update when toggled via. transmission-remote. to Alternate speed (turtle) button does not update when toggled via RPC

comment:4 Changed 11 years ago by charles

the fix was in r11215, however, it had a small bug in it that's been resolved in r11261

Note: See TracTickets for help on using tickets.