Opened 11 years ago

Closed 11 years ago

#3564 closed Bug (duplicate)

Crash in Curl_done()

Reported by: Mosstromo Owned by:
Priority: Normal Milestone: None Set
Component: Transmission Version: 2.01
Severity: Normal Keywords: crash, mac
Cc:

Description

Transmission version 2.01 (build 10898)

It's been a couple of weeks now that suddenly Transmission has started crashing very often while it works at night. Since it has been unattended at the time I do not know the steps that caused the crash (only when I wake several hours later is that I discover the catastrophe), but I am including a text file with the report that Apple generates for each crash, as well as my OS specs in it. The file includes 3 different crashes within a short span.

All I can mention, besides what is inside the text file report, is that I have been seeding heavily (but within the parameters I assigned the application) and downloading lightly at the moment. About 50 or so active files at any moment.

Attachments (1)

3_crashes-apple_report.txt (81.3 KB) - added by Mosstromo 11 years ago.
Three (3) crash reports generated by Apple's OSX

Download all attachments as: .zip

Change History (4)

Changed 11 years ago by Mosstromo

Three (3) crash reports generated by Apple's OSX

comment:1 Changed 11 years ago by livings124

Could you please see if you can replicate this with the current nightly build (http://transmission.xpjets.com/).

comment:2 Changed 11 years ago by charles

  • Keywords sudden unexplained overnight unattended removed
  • Summary changed from Unexplained crash (when running over night). to Crash in Curl_done()
Thread 2 Crashed:
67	0   libcurl.4.dylib                     0x0012b26c Curl_done + 27
68	1   libcurl.4.dylib                     0x0013d95d curl_multi_add_handle + 1918
69	2   libcurl.4.dylib                     0x0013dff6 curl_multi_perform + 97
70	3   org.m0k.transmission                0x0009e032 0x1000 + 643122
71	4   org.m0k.transmission                0x00071a90 0x1000 + 461456
72	5   libSystem.B.dylib                   0x95cce155 _pthread_start + 321
73	6   libSystem.B.dylib                   0x95cce012 thread_start + 34

comment:3 Changed 11 years ago by charles

  • Resolution set to duplicate
  • Status changed from new to closed

This appears to be a duplicate of #3544

Note: See TracTickets for help on using tickets.