Opened 11 years ago

Closed 10 years ago

Last modified 10 years ago

#3576 closed Bug (invalid)

Does transmission send wrong data? (no)

Reported by: Seiduna Owned by:
Priority: Normal Milestone: None Set
Component: Transmission Version: 1.92
Severity: Normal Keywords: needinfo
Cc:

Description

Hello,

I have just been banned from private tracker, because I changed some keys - as they say. I have not make any changes to my Transmission for a while now. They say that they work on statistic that my client is sending them, so Transmission. And they say that it shows, that there is no download registered, just upload. For all my torrents. I had ratio somewhere around 2 000 000!!! My original ratio was like 1.4 or so.

They say I should adjust my Transmission in order to continue to use it on their site.

I can provide all info you need.

I use Gentoo OS, 64 bit.

Thank you, Seiduna

Change History (30)

comment:1 Changed 11 years ago by charles

  • Keywords needinfo added; incorrect upload/download banned removed
  • Priority changed from Highest to Normal
  • Severity changed from Blocker to Normal

What I would need to investigate this is the contents of the announces that Transmission sent to the tracker.

I have no idea what you mean when you say "changed some keys" or "adjust my Transmission."

comment:2 Changed 11 years ago by Seiduna

Hello Charles, I do not know either what these key are. I was accused of changing the keys, and that resulted in my HUGE ratio. They said, if I did not mess (which I did not!) I should adjust my Transmission' settings.

I would gladly send you the "contents of the announces that Transmission sent to the tracker", for that I ask you kindly to direct me how to obtain that.

comment:3 Changed 11 years ago by charles

Transmission doesn't log that information anywhere -- that would be a nasty privacy risk. You would need to get them from the tracker admins.

comment:4 Changed 11 years ago by Seiduna

Hello Charles, and thank you for your time!

I contacted the admins and asked them to either join the conversation here, or to send me that report.

I hope to hear from them soon, hopefully here.

comment:5 Changed 11 years ago by charles

For the benefit of any tracker admins:

I'm not aware of any bugs that would cause behavior like what's been described here. There were some announce issues in 1.8x, but 1.9x has been bundled on various Linux distros for half a year now and I've heard no other reports of it incorrectly sending "downloaded=0".

Looking through the tickets closed between the user's version (1.92) and the current version (2.04), the only ticket that looks even vaguely close is #3308, which may affect users using an the "incomplete directory" feature and xbtt trackers. However I don't have any real-world reports of it causing trouble, either.

comment:6 follow-up: Changed 11 years ago by User294

At least rutracker.org (former torrents.ru), biggest Russian torrent tracker unfortunately lists Transmission as "not recommended" client :(. As far as I know, this is due to weird up/down stats which could be occasionally sent to tracker as up and/or down numbers. Then tracker auto-bans "cheating" user, causing some headaches to unban account. They have automated monitoring intended to punish people who're cheating by sending weird values for up and down manually. Generally I made some tests and haven't found anything wrong as well as I haven't been banned anyhow soon. But I suspect there could be some bug(s) lurking here at least in some versions. For example, what would happen if torrent added and then completed/almost completed file found on disk (at recheck, adding, etc)? Will Transmission report data fetched from disk as "downloaded", even if they're fetched locally? Trackers may have simple math like that: if you've "downloaded" or "uploaded" some 500 Mbytes in just two seconds, you're reporting that you have 2.5G link, hence you lie about your stats and subject to ban as "ratio hacker". I suspect that Transmission could toggle such countermeasures in some conditions, yet I haven't found which corner case would cause this behavior and it's not what I'm using ratio based trackers too much myself.

comment:7 in reply to: ↑ 6 Changed 11 years ago by charles

Replying to User294:

At least rutracker.org (former torrents.ru), biggest Russian torrent tracker unfortunately lists Transmission as "not recommended" client :(. As far as I know, this is due to weird up/down stats which could be occasionally sent to tracker as up and/or down numbers.

I'm not sure what you expect the Transmission team to do with this comment. Do you have a specific claim?

Generally I made some tests and haven't found anything wrong as well as I haven't been banned anyhow soon. But I suspect there could be some bug(s) lurking here at least in some versions.

Same here.

For example, what would happen if torrent added and then completed/almost completed file found on disk (at recheck, adding, etc)?

It will report exactly what the BitTorrent? spec requires: the number of bytes downloaded since the last 'started' event was sent.

Will Transmission report data fetched from disk as "downloaded", even if they're fetched locally?

No.

comment:8 Changed 11 years ago by charles

  • Summary changed from I got banned from private tracker since transmission sends wrong data to I got banned from private tracker. Does transmission send wrong data?

comment:9 Changed 11 years ago by charles

It's been a week since the original report and so far there are no details for the Transmission development team to look at. Seiduna, is there any news on this?

comment:10 Changed 11 years ago by Seiduna

Hello Charles, I wrote before to admins to give the needed data, either to joun here or to pass it to me. So far they did not respond... Just now I asked them again.

I am afraid that I can not do much more, but give it a day or two for them to give a feedback...

Thank you, Seiduna

comment:11 Changed 11 years ago by Seiduna

Hello, I got some answer. I must say I am disappointed in their support, since they did not remember me... We are the country with 2 million people, so either they have a lot of complains, or they do not give a damn...

They say: "this is what your client send us; first number is upload, second is download (you have all set at 0) and last number is ratio. That means that your client do not keep the record that you have actually downloaded anything, but only keeps record of what you uploaded, therefore so hudge ratio."

LEGEND: torrent (xy) upload download ratio

xy

0.0 kB

0.0 kB

1.00

xy

0.0 kB

11.3 MB

0.00

xy

261.5 kB

0.0 kB

267777.00

xy

183.4 MB

0.0 kB

192293566.00

xy

105.3 MB

0.0 kB

110403773.00

xy

77.8 MB

0.0 kB

81591204.00

xy

399.6 MB

0.0 kB

419037851.00

xy

141.9 MB

0.0 kB

148784361.00

xy

196.7 MB

0.0 kB

206214441.00

xy

1.45 GB

0.0 kB

1559605577.00

xy

246.4 MB

0.0 kB

258344277.00

xy

4.31 GB

0.0 kB

4627812142.00

xy

1.14 GB

0.0 kB

1220996153.00

xy

0.99 GB

0.0 kB

1057637783.00

xy

709.9 MB

0.0 kB

744428381.00

xy

2.53 GB

0.0 kB

2721498066.00

xy

1.37 GB

0.0 kB

1469341661.00

xy

9.5 MB

1.37 GB

0.01

xy

0.99 GB

0.0 kB

1060593569.00

xy

580.8 MB

0.0 kB

608992953.00

xy

1.03 GB

0.0 kB

1106262054.00

xy

235.3 MB

0.0 kB

246689322.00

xy

1.03 GB

0.0 kB

1105043668.00

xy

1.30 GB

0.0 kB

1391528853.00

xy

4.87 GB

1.37 GB

3.56

xy

4.52 GB

0.0 kB

4855680780.00

xy

1.33 GB

0.0 kB

1430369460.00

xy

668.9 MB

0.0 kB

701440253.00

xy

1.01 GB

0.0 kB

1085118178.00

xy

1.92 GB

0.0 kB

2058057104.00

xy

2.22 GB

0.0 kB

2387433108.00

xy

4.06 GB

0.0 kB

4363410204.00

xy

672.1 MB

0.0 kB

704721565.00

xy

2.24 GB

0.0 kB

2405104459.00

xy

483.1 MB

0.0 kB

506619316.00

xy

889.5 MB

0.0 kB

932696488.00

xy

1.46 GB

0.0 kB

1569641547.00

xy

1.96 GB

0.0 kB

2109180094.00

xy

10.91 GB

0.0 kB

11712043096.00

xy

3.25 GB

0.0 kB

3489323258.00

xy

2.06 GB

0.0 kB

2209085823.00

xy

1.81 GB

0.0 kB

1940114626.00

xy

4.87 GB

0.0 kB

5232730566.00

xy

2.29 GB

0.0 kB

2458071008.00

xy

1.48 GB

472.7 kB

3278.00

xy

2.26 GB

0.0 kB

2424993359.00

xy

1.45 GB

0.0 kB

1561705776.00

xy

9.36 GB

0.0 kB

10046953396.00

xy

1.95 GB

0.0 kB

2095568628.00

xy

3.30 GB

0.0 kB

3538390768.00

Well, I think I am done with them...

I am grateful for all your time and input, but I moved on and found other trackers.

Thank you all!

Kind regards, Seiduna

comment:12 Changed 11 years ago by charles

  • Resolution set to invalid
  • Status changed from new to closed

comment:13 Changed 10 years ago by howl

I'm seeing this with Transmission 2.11 in the tracker I'm staffer, for now only two members with that version, but this only happens sometimes. The reported downloaded, and also uploaded are lower than the previous values.

We have recreated the reports from the webserver log to make sure the problem is not in the tracker. It's late now so tomorrow I will paste them here if we have the permission of the members (without ip of course).

PD: The logs show a very little information in Spanish (in fact are only auto-notes about down/up being lower than the report n-1), could be pasted as is or better translated to English?

comment:14 Changed 10 years ago by howl

  • Resolution invalid deleted
  • Status changed from closed to reopened

comment:15 Changed 10 years ago by livings124

  • Summary changed from I got banned from private tracker. Does transmission send wrong data? to Does transmission send wrong data?

comment:16 Changed 10 years ago by charles

howl, if you think there may be privacy issues with the data wrt IP addresses etc, mail the log to dev@trans... instead of attaching it here in public.

comment:17 Changed 10 years ago by howl

Ok, emailed the logs.

Forget to say, the first three logs are from a member that uses Ubuntu Lucid, and the last three are from a member that uses Mac OS X 10.6.4.

Last edited 10 years ago by howl (previous) (diff)

comment:18 Changed 10 years ago by howl

We have detected more issues, there is one member with 2.11 that have reports with double started event each with two different keys from the same transmission, and then the reports continue to be double, alternating one and another key. This reports also suffer from not acumulating previous down up bytes. also we have to recover the event value, but seems to be event=t20 in some of the reports.

comment:19 Changed 10 years ago by charles

howl, it looks like the issue described in your email is #3666 which is fixed in trunk for 2.12.

Last edited 10 years ago by charles (previous) (diff)

comment:20 Changed 10 years ago by howl

Yes the issue described about the about not accumulating up down is the same. We will wait for 2.12 and then ask members to upgrade to block 2.10 and 2.11 to avoid problems.

But the other issue about double report per torrent with two different keys doesn't seems to be the same, could file a new bug and send reports about that if needed and close this as duplicate, waiting for orders :)

comment:21 follow-up: Changed 10 years ago by charles

Please mail me the logs for that second issue. I do not completely understand the description, but maybe reading the logs will help.

comment:22 in reply to: ↑ 21 Changed 10 years ago by howl

Replying to charles:

Please mail me the logs for that second issue. I do not completely understand the description, but maybe reading the logs will help.

I will try to send them tomorrow, if not any other day of this new week. Sorry about my lack of english expression :)

comment:23 Changed 10 years ago by charles

Thanks Howl :)

comment:24 Changed 10 years ago by charles

Howl, any news on this?

comment:25 Changed 10 years ago by howl

Sorry I generated the logs but didn't send, they are now. Certainly there are news, this member uses a My Book world edition from Western Digital. I think that a double execution of Transmission could happen, and I suggested him to check with pstree the next time this happens again, but, I doesn't happen one more time since them.

comment:26 Changed 10 years ago by Seiduna

Ola, I am following this Ticket via email, and if it is any help, I also use My Book 500GB usb external disk, from Western Digital. kind regards

comment:27 Changed 10 years ago by charles

Howl, if the two key issue is still happening, please open a new ticket for it. I think you're right that ticket #3576 has too many topics.

comment:28 Changed 10 years ago by charles

  • Resolution set to invalid
  • Status changed from reopened to closed
  • Summary changed from Does transmission send wrong data? to Does transmission send wrong data? (no)

Reclosing this ticket as it was in comment:13. the other question asked by howl should have its own ticket.

comment:29 Changed 10 years ago by howl

I will do it, but for now it hasn't happened again.

comment:30 Changed 10 years ago by charles

Thank you howl

Note: See TracTickets for help on using tickets.