Opened 11 years ago

Closed 10 years ago

#3580 closed Enhancement (fixed)

request: transmission-remote manual update trackers option

Reported by: gunzip Owned by: charles
Priority: Normal Milestone: 2.20
Component: Daemon Version: 2.04
Severity: Normal Keywords:
Cc:

Description

OS Linux Debian, transmission-daemon 2.04+ (11265)

it would be useful for those not running the gtk version to be able to manually update (reannounce) trackers on a specific torrent, something like:

transmission-remote -t <ID> --tracker-update

as it stands now sending a SIGHUP to transmission-daemon is only way to do it, but it has several drawbacks:

1) it updates trackers for all running torrents when this is really not necessary or desired

2) by re-reading the settings.json file, any current changes in speed limits or for that matter any other tweaks are lost and have to be reset

3) it disallows the use of peer-port-random-on-start, as the SIGHUP will abruptly change the peer listen port on all running torrents

On a side note, there is no documentation of SIGHUP in the transmission-daemon manual, but it is mentioned in the transmission-cli one.

Change History (7)

comment:1 Changed 11 years ago by charles

  • Milestone changed from None Set to 2.20
  • Owner set to charles
  • Status changed from new to assigned
  • Version changed from 2.04+ to 2.04

I'll put this in after the 2.10 freeze is over

comment:2 Changed 10 years ago by charles

  • Resolution set to fixed
  • Status changed from assigned to closed

added to trunk in r11518

comment:3 Changed 10 years ago by gunzip

thanks for adding this in .. and it seems to be all working as advertised


transmission-daemon 2.13+ (11522)

comment:4 Changed 10 years ago by gunzip

  • Resolution fixed deleted
  • Status changed from closed to reopened
  • Summary changed from feature request: transmission-remote manual update trackers option to regression: transmission-remote manual update trackers option broken
  • Type changed from Enhancement to Bug

OS Linux Debian, transmission-daemon 2.13+ (11615)

something caused this feature to stop working in the recent nightlies (possibly the intro of libevent2?) as it tested fine before that (r11518 was OK).

i fired up wireshark just to confirm that the "GET /announce?info_hash=..." is no longer being sent, even though transmission-remote -t <ID> --reannounce responds "success".

comment:5 Changed 10 years ago by jordan

gunzip, are you reannouncing too fast?

Transmission won't reannounce if (current time - last announce time) < tracker's minimum announce interval

comment:6 Changed 10 years ago by gunzip

@jordan: no, i tested this behavior pretty thoroughly even waiting over 25 minutes on a public tracker. also i tested this on a private tracker which has no minimum interval.

when i tried the exact same trackers with rTorrent, i had no trouble reannouncing even after 1 minute.

i've had no success getting this feature to work at all with TR anymore, i.e. it's totally broken on my end.

comment:7 Changed 10 years ago by gunzip

  • Resolution set to fixed
  • Status changed from reopened to closed
  • Summary changed from regression: transmission-remote manual update trackers option broken to request: transmission-remote manual update trackers option
  • Type changed from Bug to Enhancement

UPDATE:

well i wasn't so thorough as i thought. i tried a second private tracker site and transmission reannounce is working there. all i can think of is there is some mimimun interval as you said but rTorrent might not always respect them, or it has the ability to override them.

anyway i'm going to change this from reopened to closed as i don't fully understand how and when this minimal interval is enforced.

sorry for the inconvenience.

Note: See TracTickets for help on using tickets.