Opened 11 years ago

Closed 11 years ago

Last modified 11 years ago

#3586 closed Bug (worksforme)

transmission doesn't remove all files when remove data file is called

Reported by: NiX Owned by:
Priority: Normal Milestone: None Set
Component: Transmission Version: 2.04
Severity: Normal Keywords:
Cc:

Description

on a running torrent, if i call remove data file, the downloaded part files are not removed.

Change History (5)

comment:1 Changed 11 years ago by livings124

I can't replicate this. What OS are you using? Did you modify any data or add files to any directories? Can you replicate this with the 2.10 beta?

comment:2 Changed 11 years ago by NiX

it happens consistently. i'm using latest svn (r11288) on mac osx. i have set the preference for appending .part to incomplete files.

i just downloaded a torrent with 20 files, let it run for a minute so there were 20 part files, right clicked on the torrent to remove data file and after the torrent was removed, the data directory still contained two of the part files. the directory and files were not modified by any other process other than transmission.

Last edited 11 years ago by NiX (previous) (diff)

comment:3 Changed 11 years ago by livings124

I sill can't reproduce this. Are you seeing the issue with the released 2.10? Are you sure the data hasn't been modified? Have you viewed any of the data in an app such as itunes, etc?

comment:4 Changed 11 years ago by livings124

  • Resolution set to worksforme
  • Status changed from new to closed

Please reopen with more information.

comment:5 Changed 11 years ago by NiX

2.11 still doesn't remove all files and directories and no other program had accessed the data. If the debug output was relevant, I would attach it. There is no other information I can give you, but if it works for your specific needs, then it must be fine for everybody else. I'm just going to switch back to a real client and not worry about it anymore.

Note: See TracTickets for help on using tickets.