Opened 12 years ago

Closed 12 years ago

#3597 closed Bug (fixed)

segfault in gtk client

Reported by: geirha Owned by: charles
Priority: Normal Milestone: None Set
Component: GTK+ Client Version: 2.04
Severity: Normal Keywords:
Cc:

Description

This is the gtk-client from the transmission ppa, Transmission 2.04 (11151).

Unfortunately it apparently doesn't have debugging symbols, so I don't know how usefull the stack-trace will be. I suspect it's related to, and possibly fixed by, ticket #3571.

The segfault appeared to happen just as it was about to verify a newly completed torrent.

Attachments (1)

stacktrace (2.6 KB) - added by geirha 12 years ago.
Output from (gdb) bt full

Download all attachments as: .zip

Change History (6)

Changed 12 years ago by geirha

Output from (gdb) bt full

comment:1 Changed 12 years ago by charles

geirha, thanks for the trace, but it's not clear to me from this trace where the problem is.

Is this crash repeatable?

comment:2 Changed 12 years ago by geirha

It's the only time I ran it with gdb and caught a segfault. I've gotten a segfault at least once before that (probably several), but I don't know if it's the same segfault. Transmission ran for almost a week non-stop before that segfault happened, so reproducing it is cumbersome.

I'm running a trunk build now (11289); it's been running fine for five days so far. If the problem still persist, it should crash within a couple of days, in which case I'll try to reproduce it again, getting a (hopefully) better stacktrace.

comment:3 Changed 12 years ago by charles

geirha, any news on this ticket?

comment:4 Changed 12 years ago by geirha

Well, the trunk build has run for 11 days straight so far, so it seems it's not an issue in newer versions.

comment:5 Changed 12 years ago by charles

  • Resolution set to fixed
  • Status changed from new to closed

I guess there's not much to do with this ticket but close it; however, I feel odd doing that when we're not sure what caused the problem.

Please do reopen this ticket if the issue appears again. Thanks!

Note: See TracTickets for help on using tickets.