Opened 11 years ago

Closed 11 years ago

#3609 closed Bug (worksforme)

Schedule times in web interface

Reported by: goldendel Owned by: goldendel
Priority: Normal Milestone: None Set
Component: Web Client Version: 2.04
Severity: Normal Keywords: incomplete, Schedule times
Cc: timthornton@…

Description

Hi,

Firstly, congratulations on creating Transmission, it's a fantastic torrent client!

I am using version 2.04(11151) running remotely on a (UNIX based) QNAP TS219P. I think I may have found a bug in the schedule time settings of the web interface and or the transmission daemon.

If the start time is later than the finish time, the speed limits never come off the temporary setting. I am using the temporary speed limits to control when the torrents download. My ISP off peak is from 2AM to 8AM. If I start the temporary speed limit at 8AM and finish at 2AM, with the download and upload speed at zero, nothing ever starts.

Many thanks for your help.

Attachments (1)

Scheduled times.JPG (32.1 KB) - added by goldendel 11 years ago.
Picture of settings

Download all attachments as: .zip

Change History (5)

Changed 11 years ago by goldendel

Picture of settings

comment:1 Changed 11 years ago by charles

Thanks for reporting this issue!

When I tested this behavior myself, the alternate speed limit mode correctly turned off at the scheduled time, then connected to peers, and then began downloading. So, in short, I'm not able to duplicate the behavior you're seeing.

But, if this is behavior that you can reproduce, the above three steps are three different ways in which it could have failed on you:

  • Did the speed limit mode turn off correctly? (such as, did the turtle color change?)
  • Did it connect to peers after turning off the turtle mode?
  • Did it download from any of the peers it connected to?
  • Were there any other known peers in the swarm? In other words, if there weren't any peers, we wouldn't be able to download regardless of the speed limit mode...

comment:2 Changed 11 years ago by charles

  • Keywords incomplete added

goldendel: ping

comment:3 in reply to: ↑ description Changed 11 years ago by goldendel

Replying to goldendel:

Hi Charles,

My apologies for the delay. In the meantime, my workaround has been to set the torrents to start at 23:45, but not power on the QNAP until 02:00 which has worked. However, it means I have to turn the QNAP off from 23:45 to 02:00 :(

I've tried to reproduce the problem in waking hours a couple of times (again tonight setting the time from 21:45 - 21:30). I've also been unable to reproduce the issue. The only thing I did differently when I saw the problem was to set the time to the next day in the middle of the night.

I know this shouldn't make a difference, but I have set the scheduled times back to 07:00 to 02:00 as before. I'll post tomorrow to let you know how I got on. FYI, someone else has reported a similar problem in response to my post on the QNAP forum: http://forum.qnap.com/viewtopic.php?f=221&t=35428#p159166

It is possible there were no seeders in the swarm in the middle of the night, but I would have thought it unlikely, as there were a number of torrents. I have picked a torrent with 171 seeds for tonight's test. Hopefully this should be sufficient.

Thanks again for your help.

Hi,

Firstly, congratulations on creating Transmission, it's a fantastic torrent client!

I am using version 2.04(11151) running remotely on a (UNIX based) QNAP TS219P. I think I may have found a bug in the schedule time settings of the web interface and or the transmission daemon.

If the start time is later than the finish time, the speed limits never come off the temporary setting. I am using the temporary speed limits to control when the torrents download. My ISP off peak is from 2AM to 8AM. If I start the temporary speed limit at 8AM and finish at 2AM, with the download and upload speed at zero, nothing ever starts.

Many thanks for your help.

comment:4 Changed 11 years ago by goldendel

  • Resolution set to worksforme
  • Status changed from new to closed

Hi Charles,

The torrent started overnight, so it must have been my error. I have marked the ticket as resolved.

Thanks for your help.

goldendel

Note: See TracTickets for help on using tickets.