Opened 11 years ago

Closed 11 years ago

#3635 closed Bug (fixed)

transient children of the main window aren't hidden when the main window is hidden to the notification area

Reported by: kovalev Owned by: charles
Priority: Lowest Milestone: 2.11
Component: GTK+ Client Version: 2.10
Severity: Trivial Keywords:
Cc:

Description

Minimizing main window of Transmission GTK client to the taskbar in Ubuntu Gnome desktop also minimizes any of Transmission's standard dialogues. This seems is what to be expected intuitively. In contrast to that, none of them gets minimized when minimizing the client to the notification area. Instead of that, such a window is remaining active and on the top. To check the behaviour: with "show Transmission icon in the notification area" set, open any standard dialogue in GTK client and then try to minimize/maximize the client's main window both ways.

Is it a feature or a minor bug?

Affected versions: seems all releases of GTK client since 1.76 (including the most recent one) running with all recent versions of Gnome desktop.

Change History (2)

comment:1 Changed 11 years ago by charles

  • Milestone changed from None Set to 2.11
  • Status changed from new to assigned

confirmed. looks like a minor bug to me.

comment:2 Changed 11 years ago by charles

  • Resolution set to fixed
  • Status changed from assigned to closed
  • Summary changed from Standard dialogue of T GTK client does not get minimized when minimizing to the notification area to transient children of the main window aren't hidden when the main window is hidden to the notification area

Fixed in trunk by r11314

Note: See TracTickets for help on using tickets.