Opened 11 years ago

Closed 11 years ago

Last modified 11 years ago

#3643 closed Bug (fixed)

Save Torrent File As... default file name has wrong extension

Reported by: jsherman256 Owned by: livings124
Priority: Normal Milestone: 2.12
Component: Mac Client Version: 2.11
Severity: Trivial Keywords: Save Torrent File As..., file extension
Cc:

Description

Description: When using contextual menu option "Save Torrent File As...", the default file name is that of the file inside of the torrent, rather than the original torrent file's name. If the user, selects the default file name (by pressing enter), an error is thrown warning the user that the file extension (in my case, '.avi') is not valid, and must be '.torrent'.

Suggested Resolution: This error message is correct--the file extension should be '.torrent'. However, the program should automatically append '.torrent' to the current string being used as the default file name when the "Save Torrent File As..." contextual menu option is selected. This would mean that using the default value would be a valid choice rather than causing an error.

Steps to Reproduce:

Client may need to be set to use the "add window" listed in the Transfers section of the preference window.

  1. Download a torrent file.
  2. Open the torrent file with Transmission (via Firefox)
  3. In the Add window, deselect "Start when added", leave "Trash Torrent File" selected, and then click "Add".
  4. Double-click the torrent in the main window. Delete all of it's trackers.
  5. Add two or three valid trackers to the list. Close the Torrent inspector.
  6. Control-click on the torrent and choose "Save Torrent File As..." from the resulting contextual menu.
  7. Note the default file name in the Save window. Click default button and note resulting error.

I have no idea whether or not the above steps are necessary to reproduce this bug. I may test it later and post the results.

Change History (8)

comment:1 Changed 11 years ago by livings124

Do you have "hide extension" selected in the window? If you deselect that it should show torrent. With it hidden it shouldn't show the warning, though - it might be a bug in the OS.

comment:2 Changed 11 years ago by jsherman256

You are 100% correct. I didn't even realize that that window had the "hide extension" option because I had never bothered to uncollapse that part of it. If you uncheck it, it does show ".torrent" and the warning is not there. I guess the question is if that is definitely a problem with the OS X framework or if it's related to a problem in Transmission's code.

comment:3 follow-up: Changed 11 years ago by livings124

I'll look into it, but that dialog's generated by the OS. I'll look into possible workarounds and file a bug report with Apple.

comment:4 in reply to: ↑ 3 Changed 11 years ago by jsherman256

Replying to livings124:

I'll look into it, but that dialog's generated by the OS. I'll look into possible workarounds and file a bug report with Apple.

Ok, thanks. You would mind posting the tracking number on Apple's bug report system? I have an account there too and am interested in seeing the resolution to this.

comment:5 Changed 11 years ago by livings124

Created Bug ID# 8562042.

comment:6 Changed 11 years ago by livings124

comment:7 Changed 11 years ago by livings124

  • Milestone changed from None Set to 2.12
  • Resolution set to fixed
  • Status changed from new to closed

comment:8 Changed 11 years ago by livings124

A response from Apple says this is intentional behavior.

Note: See TracTickets for help on using tickets.