Opened 11 years ago

Closed 11 years ago

#3644 closed Bug (fixed)

About Dialog always appear with main window

Reported by: Andru Owned by: charles
Priority: Low Milestone: 2.12
Component: GTK+ Client Version: 2.11
Severity: Trivial Keywords:
Cc:

Description

Steps to reproduce:

  • run Transmission
  • Help->About
  • hide Transmission to systray
  • show Transmission by double-clicking on icon in systray

After last step Transmission will show main window and "About Transmission". Every next hide/show operation reproduce this bug.

Attachments (1)

windows.patch (2.1 KB) - added by charles 11 years ago.

Download all attachments as: .zip

Change History (8)

comment:1 Changed 11 years ago by Andru

Oh, I have forgot one step - close "About Transmission" after step "Help->About"

Version 0, edited 11 years ago by Andru (next)

comment:2 Changed 11 years ago by charles

  • Milestone changed from None Set to 2.12
  • Status changed from new to assigned

This appears to be a side-effect of #3635

comment:3 Changed 11 years ago by charles

  • Resolution set to fixed
  • Status changed from assigned to closed

Fixed in trunk by r11336.

Thanks for reporting this!

comment:4 Changed 11 years ago by kovalev

  • Priority changed from Normal to Low
  • Resolution fixed deleted
  • Severity changed from Normal to Trivial
  • Status changed from closed to reopened

Since r11336 both "About Transmission" and "Message Log" are not hidden at all when hiding GTK client's main window to the notification area.

Just a minor issue.

comment:5 follow-up: Changed 11 years ago by charles

Well I'm not going to add another svn commit and mark this as "fixed" again until someone's confirmed it :)

Attached is a patch that should fix the new issue for the About and Message Log windows. I've tested it out and don't see any issues with the other windows, but who knows, maybe I missed one. Andru, kovalev, could you apply this patch and give it a test?

Changed 11 years ago by charles

comment:6 in reply to: ↑ 5 Changed 11 years ago by kovalev

Replying to charles:

Well I'm not going to add another svn commit and mark this as "fixed" again until someone's confirmed it :)

Attached is a patch that should fix the new issue for the About and Message Log windows. I've tested it out and don't see any issues with the other windows, but who knows, maybe I missed one. Andru, kovalev, could you apply this patch and give it a test?

Confirmed - the patch seems solved the issue for all child windows.

comment:7 Changed 11 years ago by charles

  • Resolution set to fixed
  • Status changed from reopened to closed

Re-fixed in trunk by r11337.

Thanks for testing, kovalev

Note: See TracTickets for help on using tickets.