Opened 11 years ago

Closed 11 years ago

#3653 closed Bug (duplicate)

script-torrent-done executed too early

Reported by: mactijn Owned by:
Priority: Normal Milestone: None Set
Component: Daemon Version: 2.10
Severity: Normal Keywords:
Cc:

Description

Currently, when a torrent is done downloading, a script is being triggered and then verification is started, which creates a race condition where the script might be accessing corrupted data.

Situation

  • {config::script-torrent-done-enabled}: true
  • {config::script-torrent-done-filename}: (set to script)
  • {config::incomplete-dir-enabled}: true
  • {config::incomplete-dir}: (set to dir)
  • {config::download-dir}: (set to dir)

Current behavior

  • a torrented download finishes
  • data is moved to {config::download-dir} from {config::incomplete-dir}
  • a script is executed
  • verification of the data is started
  • possible corrupted pieces are re-downloaded

Expected behavior

  • a torrented download finishes
  • data is moved to {config::download-dir} from {config::incomplete-dir}
  • verification of the data is started
    • corruption is found
      • corrupted pieces are re-downloaded
      • restart verification
    • corruption is not found
      • a script is executed

Change History (3)

comment:1 Changed 11 years ago by mactijn

not verified yet on 2.11 since I just installed this. Changelogs suggest this behavior has not been altered.

comment:2 Changed 11 years ago by mactijn

The same behavior is observed on 2.11 and nightly builds.

comment:3 Changed 11 years ago by charles

  • Resolution set to duplicate
  • Status changed from new to closed

This will be fixed by changing how Transmission verifies torrents as per ticket #2955. Closing this as a duplicate of #2955.

Note: See TracTickets for help on using tickets.