Opened 11 years ago

Closed 11 years ago

#3676 closed Bug (worksforme)

kernel[0]: dlil_output: output error retval = 37

Reported by: wooknoz Owned by: livings124
Priority: Normal Milestone: None Set
Component: Mac Client Version: 2.11
Severity: Critical Keywords:
Cc:

Description

Hi,

I'm having this error on my Mac Mini G4, 10.5.8 This thing seems to lead to computer crash after a while (grey fatal warning on whole screen, restart button only option). This issue has been plaguing many transmission releases: I keep using newer ones, but the problem is still there (even back to 1.93).

Thanks for any help!

Sample system log below: Oct 26 08:32:59 83-120 kernel[0]: al = 37 Oct 26 08:32:59 83-120 kernel[0]: dlil_output: output error retval = 37 Oct 26 08:32:59: --- last message repeated 15 times --- Oct 26 08:32:59 83-120 kernel[0]: al = 37 Oct 26 08:32:59 83-120 kernel[0]: dlil_output: output error retval = 37 Oct 26 08:33:00: --- last message repeated 35 times --- Oct 26 08:33:00 83-120 kernel[0]: al = 37 Oct 26 08:33:00 83-120 kernel[0]: dlil_output: output error retval = 37 Oct 26 08:33:00: --- last message repeated 23 times --- Oct 26 08:33:00 83-120 kernel[0]: al = 37 Oct 26 08:33:00 83-120 kernel[0]: dlil_output: output error retval = 37 Oct 26 08:33:01: --- last message repeated 39 times --- Oct 26 08:33:01 83-120 kernel[0]: ror retval = 37 Oct 26 08:33:01 83-120 kernel[0]: dlil_output: output error retval = 37 Oct 26 08:33:02: --- last message repeated 41 times --- Oct 26 08:33:02 83-120 kernel[0]: ror retval = 37 Oct 26 08:33:02 83-120 kernel[0]: dlil_output: output error retval = 37 Oct 26 08:33:03: --- last message repeated 72 times --- Oct 26 08:33:03 83-120 kernel[0]: ror retval = 37 Oct 26 08:33:03 83-120 kernel[0]: dlil_output: output error retval = 37 Oct 26 08:33:04: --- last message repeated 38 times --- Oct 26 08:33:04 83-120 kernel[0]: al = 37 Oct 26 08:33:04 83-120 kernel[0]: dlil_output: output error retval = 37 Oct 26 08:33:04: --- last message repeated 11 times --- Oct 26 08:33:04 83-120 kernel[0]: al = 37 Oct 26 08:33:04 83-120 kernel[0]: dlil_output: output error retval = 37 Oct 26 08:33:05: --- last message repeated 46 times --- Oct 26 08:33:05 83-120 kernel[0]: ror retval = 37 Oct 26 08:33:05 83-120 kernel[0]: dlil_output: output error retval = 37

Change History (8)

comment:1 Changed 11 years ago by wooknoz

  • Severity changed from Normal to Critical

comment:2 Changed 11 years ago by charles

  • Component changed from Transmission to Mac Client
  • Owner set to livings124

comment:3 Changed 11 years ago by wooknoz

error rate seems to increase with DL throughput

comment:4 Changed 11 years ago by livings124

You need to limit the number of connections Transmission allows (in prefs and the inspector for already-added transfers), limit speeds, and limit the number of active transfers. The problem is that your system/network cannot handle the amount of network activity.

comment:5 Changed 11 years ago by wooknoz

Really? How could I figure this out (which limit to set, when, etc)? Shouldn't transmission tune this by itself or send user-friendly warnings: I can't tell what my setup limitations are, and looking into system logs is not what you'd expect from std users. Thanks for this tip, but would appreciate if you could elaborate more, and let Transmission be smarter to figure this out by itself. Thanks for all the great work!

comment:6 Changed 11 years ago by livings124

Transmission cannot know what your system limits are. Transmission sets it to values that works for most users. Perhaps you increased the values yourself? There is a warning under the peer limit setting.

comment:7 Changed 11 years ago by wooknoz

Sorry for n00b questions but: my mac is running Transmission which seems to generate systems errors: can't Transmission catch these errors, or get to hear about them, and then trim down its own (transmission's) activity so that there is no more errors? I don't think I changed any default settings: hard to tell which one in particular is the culprit (speed, number of pears/transfer, total number of peers, etc): is there some proper way or order to tune these, or is that all by chance?

comment:8 Changed 11 years ago by livings124

  • Resolution set to worksforme
  • Status changed from new to closed

Transmission cannot catch these errors. Tuning this requires a lot of guesswork.

Note: See TracTickets for help on using tickets.