Opened 11 years ago

Closed 11 years ago

#3682 closed Enhancement (fixed)

Reduce memory footprint caused by tr_history

Reported by: Longinus00 Owned by: Longinus00
Priority: Normal Milestone: 2.13
Component: libtransmission Version: 2.11
Severity: Minor Keywords:
Cc:

Description

tr_history currently uses too much memory for what it's trying to accomplish.

Attachments (1)

fixHistory.patch (12.6 KB) - added by Longinus00 11 years ago.
V2 - mucked around with the declaration

Download all attachments as: .zip

Change History (6)

comment:1 Changed 11 years ago by charles

  • Component changed from Transmission to libtransmission
  • Owner set to Longinus00
  • Severity changed from Normal to Minor

comment:2 Changed 11 years ago by charles

  • Milestone changed from None Set to 2.12

It looks like we're only using history for {blocks,cancels}SentTo?{Client,Peer} and noBlocksCancelsCount. I agree, none of those uses require fraction-of-a-second precision.

Changed 11 years ago by Longinus00

V2 - mucked around with the declaration

comment:3 Changed 11 years ago by charles

  • Milestone changed from 2.12 to Sometime

comment:4 Changed 11 years ago by charles

This looks safe & good but I don't want to commit it right before 2.12. Bumping the milestone.

comment:5 Changed 11 years ago by charles

  • Milestone changed from Sometime to 2.13
  • Resolution set to fixed
  • Status changed from new to closed

charles * r11425 libtransmission/ (history.c history.h peer-mgr.c peer-msgs.c): (trunk libT) #3682 "reduce memory footprint caused by tr_history" -- done. Patch by Longinus00

Note: See TracTickets for help on using tickets.