Opened 11 years ago

Closed 10 years ago

#3713 closed Bug (invalid)

Transmission dies if 2 partitions used for torrents

Reported by: tman Owned by:
Priority: Normal Milestone: None Set
Component: Transmission Version: 2.11
Severity: Normal Keywords: multiple partitions location
Cc:

Description

I'm running tr 2.11 on Fonera 2.0N device, linux embedded. Bellow is the ticket I already opened on fonosfera.org, so I will just paste it here.

Transmission 2.11 installed on F2N 2.3.6.1 (valleri version, see forum.fon.com/forum). Default torrent dir is /tmp/mounts/Disc-A1/torrent, with many torrents in the default directory. Some of them I move to /../Disc-A2/torrent1 (with help of external GUI program, like Tr Remote Dotnet) After files are moved apparently it's working, but after some time Transmission dies. In F2N webUI the list is empty, at the bottom the settings dissapeared, no access with external WebUI program. Reboot F2N does not help, Tr. is dead forever, I had to reinstall it from scratch. P.S.: Disc-A1 and Disc-A2 is the same HD, multipartitioned. A1 is 700GB, A2 is 500GB, A3 is 300GB, total 1.5TB. Filesystem is EXT. (not sure which ext...formatted a log time ago on another PC)

Change History (11)

comment:1 Changed 11 years ago by charles

I see you've set this milestone for a release that's scheduled to come out in about 10 days. Does that mean you have a tested patch ready to submit?

Also, was there a crash report or backtrace associated with this crash?

comment:2 follow-up: Changed 11 years ago by tman

  • Milestone changed from 2.12 to None Set

comment:3 in reply to: ↑ 2 Changed 11 years ago by tman

Replying to tman: Sorry i set 2.12 by mistake, it's my first ticket.. I don't have any solution, I'm not a programmer just user. About backtrace/crashreport...how can I get this data ? If you can point me to some instructions I can try to do it. Thanks!

comment:4 Changed 11 years ago by tman

The root cause of this error seems to be: -tr started and using data from Disc-A1 and Disc-A2, but files from Disc-A2 are not used for a while (e.g. no peers for the torrents), -disc-A2 is ummounted by linux because it's idle -peers shows up for torrents located on discA2 error! Transmission tries to seed the torrents but cannot find the files and cannot mount the drive A2 ! >> crash ! This unmount issue explains also other errors of transmisson, like 'change location' errors, etc..

comment:5 Changed 11 years ago by charles

When transmission tries to read from a file it can't access, it should just return an error instead of crashing. In fact, I've just confirmed that behavior on my Linux laptop. ... I wish I knew more about Fon's device I wish I knew more about the Fon device to try and test this out. Is there a Fon support forum where a Fon tech can try to reproduce this issue and get a crash report for you and me?

comment:6 Changed 11 years ago by tman

http://forum.fon.com/forum is the forum for tech support. Matthijs is the responsible dev person for Fonera 2.0N device.

comment:7 Changed 11 years ago by tman

trac for Fonera 2.0N device (and others) is: http://trac.fonosfera.org/fon-ng. Same ticket opened there: http://trac.fonosfera.org/fon-ng/ticket/956

comment:8 Changed 11 years ago by jordan

I'd like to figure out if there's a way to fix this "upstream" in Transmission rather than in FoN but I haven't heard back from anyone on this, either here or in the fonosfera ticket. Would it be possible for you to provide a crash report / backtrace as in comment:5?

comment:9 Changed 11 years ago by tman

crash report / backtrace - how ? I never done that, need some tutorial. Can provide a link of how-to ?

comment:10 Changed 11 years ago by jordan

I have no idea how this is done on a FoN device, unfortunately. That would probably be a question for matthijs.

comment:11 Changed 10 years ago by livings124

  • Resolution set to invalid
  • Status changed from new to closed

Please reopen with more information. This looks to be an upstream issue.

Note: See TracTickets for help on using tickets.