Opened 11 years ago

Closed 11 years ago

#3722 closed Enhancement (worksforme)

Filtering torrents

Reported by: Shnurapet Owned by: charles
Priority: Normal Milestone: None Set
Component: GTK+ Client Version: 2.11
Severity: Normal Keywords:
Cc:

Description

Transmission 2.11 (11322) on Fedora 14

transmission-common-2.11-1.fc14.x86_64, transmission-gtk-2.11-1.fc14.x86_64

The version 1.9x offered a fast (and convenient) way to jump between the torrent categories (All / Active / Seeding / Paused). The version 2.11 introduced the two new controls that are slighly complicated and bring mouse-clicking and some kind of a mess into the options available. I have more than 1.5 hundred torrents on my list that changes daily and it is hard to manage them now. It was much easier and faster to click a button to see what's in a category because I didn't even have to read it's label or find it in the combo box as I knew the order they came in.

I suppose it'd be pointless to ask to revert the change or add the old functionality as option as T is "A Fast, Easy, and Free BitTorrent? client". But, please, do something to the new control, it's way informative, but pretty unusable.

GTK+ applications (Nautilus; Gedit; Gnome-terminal; Sonata; Pidgin; Firefox) use tabs when it comes to such kind of switching lists. This method has formed a certain habit in using programs.

Attachments (2)

Sonata_mpd_interface.png (55.5 KB) - added by Shnurapet 11 years ago.
bt.png (92.8 KB) - added by Shnurapet 11 years ago.

Download all attachments as: .zip

Change History (16)

Changed 11 years ago by Shnurapet

comment:1 Changed 11 years ago by charles

Okay, first off: "unusable filters"? All of the 1.9x filters are still there, and the added cost to use them is a single extra mouseclick. So I think you're being deliberately provocative when you say that makes them "way unusable" or a "mess."

If you feel that you're not exaggerating, could you provide a use case where the new filters make filtering 1.5 hundred torrents an unusable mess?

The Sonata tabs are to switch between different lists of items. Filters act upon the same list of items.

comment:2 Changed 11 years ago by Shnurapet

The cost is not a "single extra mouseclick" if you read into. And that's what I said: it's not as usable as it used to be.

comment:3 Changed 11 years ago by charles

The cost to switch filters before was a mouseclick. It's now two mouseclicks (one to activate the combobox, one to select an item in the combobox).

I don't know what you mean by "if you read into."

If you feel that you're not exaggerating, could you provide a use case where the new filters make filtering 1.5 hundred torrents an unusable mess?

comment:4 Changed 11 years ago by Shnurapet

Charles, I mean that if you had read into my first post you wouldn't have to repeat same questions twice. Having used the new version, all I want to say is the two combo boxes bug the hell out of me, but somehow I spent 30 minutes trying to explain what I do not like about the program and what could be a possible way to do it. You don't like tabs. That's OK. Can you remove that "extra single click" from the panel?

comment:5 Changed 11 years ago by charles

Shnurapet,

I took a moment and went over to your fedoraproject user page for a moment to remind myself that you are a real person and probably not intentionally trolling. I love the Yeti costume...

Still... please be polite. You're coming to me asking for me to do something. Does it really inconvenience you so much to be asked for clarification?

Re-re-reading through your original message, I see a lot "unusable mess" talk, and some side discussion about 1.5 hundred torrents, but I still don't find any specifics except that you like the old version because you'd memorized the filters and didn't have to look at them. If this is the insight that you wanted me to hunt for, I find it lacking. How is memorizing 1.9x's layout any different than memorizing 2.0x's layout?

At any rate... there is a tradeoff there between extra clicking and adding more filter combinations. I have tried to think of ways to reduce the number of mouse clicks and to improve keyboard shortcuts... If you have a suggestion on how to do this, in the same toolbar real estate, without losing the new features, I would be grateful for the suggestions.

Last edited 11 years ago by charles (previous) (diff)

comment:6 Changed 11 years ago by charles

  • Component changed from Transmission to GTK+ Client
  • Keywords needinfo added
  • Owner set to charles
  • Type changed from Bug to Enhancement

comment:7 Changed 11 years ago by charles

followup: http://lists.fedoraproject.org/pipermail/design-team/2010-November/003646.html

I do think it's very good that you've taken notice of this change though... The difference between one and two mouse clicks will not sound shocking on its own, but these changes can quickly add up. Transmission is known for its simplicity and I personally think that's very valuable. I can only tell them to be careful, but I'm sure the developers know this. :)

Yes.

The new filterbar was a challenging design. The goal was to copy the "power user" filtering abilities from uTorrent and Deluge but without doing too much damage to Transmission's simplicity. For example, a real sidebar was out of the question, Drop-downs seemed like a good tradeoff for preserving the layout and save real estate. Also, being able to combine the two dropdowns gives more filtering options than the clients I copied, and does so in an intuitive way.

Using drop-downs also gave me more space to add the torrent counts on the rhs of each row in the dropdown. Several people had asked for this information before but it never looked right in the old filterbar's buttons.

What I *would* do however is give the default selection in the drop-down list a better label. In your screenshot they both say "All 3", which doesn't make clear what they do. Maybe something like "All torrents", "All states" or "All trackers" would be clearer here? Just an idea.

:)

This was discussed during design. The second drop-down is the troublemaker -- it switches between being a tracker filter, a public/private filter, and a high/normal/low priority filter. This makes all my use cases easy for an end user to do, but it did thwart all attempts at naming. Since "All" and "All States" looked odd side-by-side, I decided to leave them both unnamed.

The tracker filter is much more important than the privacy or priority filer. We could arguably remove the latter two and have the second dropdown be dedicated to only trackers...

Last edited 11 years ago by charles (previous) (diff)

comment:8 Changed 11 years ago by charles

...I wonder, would it make sense to add mnemonics to the status dropdown items?

comment:9 Changed 11 years ago by charles

  • Resolution set to invalid
  • Status changed from new to closed

At this point, this ticket doesn't have any specific suggestions. It's just a complaint about the current implementation. It's also been stuck for a fortnight, so I'm going to close this as incomplete.

If you have specific suggestions on how to make the current filterbar more usable, I would be happy to consider them. I agree that there was a tradeoff involved in the new filters, even if we disagree on the size of that tradeoff. :)

comment:10 Changed 11 years ago by Shnurapet

  • Keywords needinfo removed
  • Resolution invalid deleted
  • Status changed from closed to reopened
  • Summary changed from Unusable new filters to Filtering torrents

Sorry for the delay. I was thinking on the way to improve the filter bar. I made a mockup so it could be discussed further.

http://shnurapet.fedorapeople.org/bt.png

I suggest converting one of the combo boxes so it allows old-style switching. Tips can be used to display info on each category. The trackers combo box remains untouched. I moved it to the toolbar, but it could stay in the filter bar.

comment:11 follow-up: Changed 11 years ago by charles

Well, okay. Thank you for making this mockup. This does return the single-click and muscle-memory aspect of 1.x, but IMO it also has several problems:

  • To save filterbar landscape, you've moved the tracker pulldown to the toolbar. It doesn't make sense there. Does it disappear when the user toggles the filterbar visibility in View > Filterbar? Why or why not?
  • I suspect you moved the tracker pulldown into the toolbar because you realized -- as I did when I prototyped the 2.0 filterbar -- that it makes the filterbar and toolbars extremely lopsided and forces the main window to be much wider than it otherwise needs to be.
  • Also to save landscape you've dropped the text. The "Home" and "Clock" icons don't make much sense at all to me. I doubt many people would equate "Home" with "Show All".
  • Also dropped, for lack of space, are the torrent counts that are shown on the right-hand side of the pulldowns. This is a real shame because IMO they are a killer feature.
  • The filterbar is now completely full, and the toolbar nearly so. The overall effect is much more cluttered than 2.x's appearance.

comment:12 in reply to: ↑ 11 Changed 11 years ago by Shnurapet

Replying to charles:

Well, okay. Thank you for making this mockup.

Yes. You are welcome.

This does return the single-click and muscle-memory aspect of 1.x, but IMO it also has several problems:

  • To save filterbar landscape, you've moved the tracker pulldown to the toolbar. It doesn't make sense there. Does it disappear when the user toggles the filterbar visibility in View > Filterbar? Why or why not?

I have *absolutely* no idea how it works even in 2.x. However, it's fine, no change requested here and it can be placed anywhere in the toolbars where apropriate or simply moved to menu.

  • I suspect you moved the tracker pulldown into the toolbar because you realized -- as I did when I prototyped the 2.0 filterbar -- that it makes the filterbar and toolbars extremely lopsided and forces the main window to be much wider than it otherwise needs to be.

No, I did it because it's like totally not needed.

  • Also to save landscape you've dropped the text. The "Home" and "Clock" icons don't make much sense at all to me. I doubt many people would equate "Home" with "Show All".

The mockup was created as a demonstration of arrangement of controls. Discussing fitness of a particular icon would be irrelevant here. When this is settled, each icon can be decided on.

  • <..> the torrent counts that are shown on the right-hand side of the pulldowns. <..> IMO they are a killer feature.

Obviously, they're not. :)

  • The filterbar is now completely full, and the toolbar nearly so. The overall effect is much more cluttered than 2.x's appearance.

We are getting close to perceiving the point. As you have mentioned, 2.x is already cluttered. This came as a consequence of adding extra "tweakers". All clutter ATM is contained inside the pulldowns. You are reading this ticket.

Changed 11 years ago by Shnurapet

comment:13 Changed 11 years ago by charles

Okay. Well three individual points stick out here: (1) I don't understand what "you are reading this ticket" means... I'm doing that because I'm trying to keep an open mind, not because I think you're right... (2) the changes you call "tweakers" have gotten a lot of positive feedback from other users, and (3) "obviously they're not"... well this is devolving into a he said / she said isn't it? I think they obviously are. :)

But minor points are less important than the Big Picture, which is that this mockup is a regression in terms of features (torrent counts), real estate (it's very cluttered), clarity (icons vs text), and and extensibility (no room for future features).

In other words, it fails the criteria I laid out in comment number 5:

At any rate... there is a tradeoff there between extra clicking and adding more filter combinations. I have tried to think of ways to reduce the number of mouse clicks and to improve keyboard shortcuts... If you have a suggestion on how to do this, in the same toolbar real estate, without losing the new features, I would be grateful for the suggestions.

So it comes back to that. If you have specific suggestions that meet these criteria, please reopen this ticket and include them.

Last edited 11 years ago by charles (previous) (diff)

comment:14 Changed 11 years ago by charles

  • Resolution set to worksforme
  • Status changed from reopened to closed
Note: See TracTickets for help on using tickets.