Opened 11 years ago

Closed 11 years ago

#3745 closed Bug (invalid)

datarootdir not defined in web and po Makefile

Reported by: starmoon Owned by:
Priority: Normal Milestone: None Set
Component: Transmission Version: 2.12
Severity: Normal Keywords:
Cc:

Description

datarootdir was removed from top confiuration. but the web and po direction still use datarootdir defines. This cause web contents install in root diretory.(/transmission/web)

Attachments (1)

2.11-web-Makefile-and-2.12-web-makefile.diff (6.0 KB) - added by charles 11 years ago.
diffs in the web/Makefiles between 2.11 and 2.12 when generated on a Fedora 13 system

Download all attachments as: .zip

Change History (8)

comment:1 Changed 11 years ago by charles

Is this different from the 2.11 tarball?

I'm not sure what's changed -- this difference wasn't intentional. I built 2.12 on a new Mint 10 box... maybe that caused it?

comment:2 Changed 11 years ago by starmoon

I compared the configure.in and Makefile.in between 2.11 and 2.12 (svc checkout). They are great deferent. 2.12 removed many "datarootdir" refreneces but web and po sub-direction.

Changed 11 years ago by charles

diffs in the web/Makefiles between 2.11 and 2.12 when generated on a Fedora 13 system

comment:3 Changed 11 years ago by charles

  • Resolution set to invalid
  • Status changed from new to closed

As shown in the above attachment, I don't see much difference between 2.11's and 2.12's Makefiles here.

Since the Makefiles are automatically generated on your system when you run the configure script, it's possible that there's been a configuration change on your system that's causing this issue.

There's no configure.in file, but there is a configure.ac file, and the only changes there between 2.11 and 2.12 were the release number.

There are no differences at all between 2.11 and 2.12's web/Makefile.in files.

comment:4 Changed 11 years ago by starmoon

  • Resolution invalid deleted
  • Status changed from closed to reopened

sorry i didn't say clear. I'm using svn checkouts. I do a fresh svc co. and this happens again. lost 'datarootdir' defination will cause 'make install' to install web contents in /transmission directory. (while a fresh untar of 2.12 and 2.11 release with same configuration do installed property)

comment:5 Changed 11 years ago by charles

  • Resolution set to invalid
  • Status changed from reopened to closed

You didn't read what I wrote.

You are the one generating the Makefile.in's when you build from svn, so this is a config issue with your machine. It is not a bug in Transmission.

comment:6 Changed 11 years ago by starmoon

  • Resolution invalid deleted
  • Status changed from closed to reopened

would you please give me the arguments passed to autogen.sh that releaed 2.12 version use? Thank you.

comment:7 Changed 11 years ago by charles

  • Resolution set to invalid
  • Status changed from reopened to closed

sure, here's what I typed:

cd Transmission
./autogen.sh
make distcheck
Note: See TracTickets for help on using tickets.