Opened 11 years ago

Closed 11 years ago

#3775 closed Bug (fixed)

"-tall" no longer works for transmission-remote

Reported by: archtaku Owned by: jordan
Priority: Normal Milestone: 2.20
Component: Daemon Version: 2.00
Severity: Normal Keywords:
Cc:

Description

When using transmission-remote to control transmission-daemon, you can no longer use the following syntax:

transmission-remote -tall --stop

You need to put a space between "-t" and "all". however, you can still leave out the space when selecting a specific torrent or torrents, so:

transmission-remotee -t1,4 --stop

will work. This regression should be fixed to allow "-tall" to be used.

Change History (3)

comment:1 Changed 11 years ago by archtaku

Sorry, made a typo. Instead of:

transmission-remotee -t1,4 --stop

I should have typed

transmission-remote -t1,4 --stop

comment:2 Changed 11 years ago by jordan

  • Owner set to jordan
  • Status changed from new to assigned

looks like this was broken in r10907 for #3368 in 2.00 when we added "-ta" as the short form of "--tracker-add". "-ta" seems to be conflicting with "-tall".

This can be fixed by making "--tracker-add"'s short form "-td" instead of "-ta"

comment:3 Changed 11 years ago by jordan

  • Milestone changed from None Set to 2.20
  • Resolution set to fixed
  • Status changed from assigned to closed
  • Version changed from 2.12 to 2.00

jordan * r11809 daemon/ (remote.c transmission-remote.1):

(trunk daemon) #3775 "'-tall' no longer works for transmission-remote" -- fixed.

looks like this was broken in r10907 for #3368 in 2.00 when we added "-ta" as the short form of "--tracker-add". "-ta" seems to be conflicting with "-tall". This can be fixed by changing --tracker-add's short form.

Note: See TracTickets for help on using tickets.