Opened 11 years ago

Closed 11 years ago

#3776 closed Bug (invalid)

Transmission-daemon crashes after the start of any torrent download

Reported by: kj17x0 Owned by:
Priority: Normal Milestone: None Set
Component: Transmission Version: 2.12
Severity: Normal Keywords: crash,
Cc:

Description

I have transmission-daemon running on my dlink dir825 wireless router running dd-wrt. I got the .ipk from downloads.openwrt.org.

The problem starts when the download starts. Transmission-web stops working and transmission remote dot net can not connect to it neither. 2.04 and 2.11 had the same problem.

Attachments (2)

syslog.doc (31.0 KB) - added by kj17x0 11 years ago.
Messages from syslog
btlog.doc (24.0 KB) - added by kj17x0 11 years ago.

Download all attachments as: .zip

Change History (19)

comment:1 follow-up: Changed 11 years ago by charles

I've had nothing but trouble trying to help people to use gdb on DD-WRT. Part of the problem is that I don't have a DD-WRT either, so I don't really know what I'm talking about. :)

Is there a DD-WRT forum that you could use where experienced DD-WRT hackers could help you with getting gdb to return a meaningful backtrace for this crash?

comment:2 Changed 11 years ago by kj17x0

Last edited 11 years ago by kj17x0 (previous) (diff)

comment:3 in reply to: ↑ 1 Changed 11 years ago by kj17x0

Replying to charles:

I've had nothing but trouble trying to help people to use gdb on DD-WRT. Part of the problem is that I don't have a DD-WRT either, so I don't really know what I'm talking about. :)

Is there a DD-WRT forum that you could use where experienced DD-WRT hackers could help you with getting gdb to return a meaningful backtrace for this crash?

I did a week ago but no one replied. Sorry but what is gdb?

comment:4 follow-up: Changed 11 years ago by charles

gdb is the GNU Debugger, which could be used to provide a backtrace that will tell us what Transmission was doing when it crashed. This seems to always be the trouble with DD-WRT bug reports. Is there maybe a different crash report tool for DD-WRT?

comment:5 in reply to: ↑ 4 Changed 11 years ago by kj17x0

Replying to charles:

gdb is the GNU Debugger, which could be used to provide a backtrace that will tell us what Transmission was doing when it crashed. This seems to always be the trouble with DD-WRT bug reports. Is there maybe a different crash report tool for DD-WRT?

Well there is a log of messages if they can help

comment:6 follow-up: Changed 11 years ago by charles

They usually don't... but it doesn't hurt to try :)

Changed 11 years ago by kj17x0

Messages from syslog

comment:7 in reply to: ↑ 6 Changed 11 years ago by kj17x0

Replying to charles:

They usually don't... but it doesn't hurt to try :)

I attached the results from syslog on ddwrt from various times. Please analyze them if you have spare time. It would be very very helpful because i think transmission is best bt client out there and the only one thats even close to work for me.

A little more info: Before the crash I can kill transmission with killall but after i have to use kill -9.

Thank you very very much :)

Last edited 11 years ago by kj17x0 (previous) (diff)

comment:8 follow-up: Changed 11 years ago by charles

kj17x0, I've looked over the log files and they don't really tell me anything about the crash. I would love to help you more on this but the first step is that you'll need to find a DD-WRT person to help you with DD-WRT tech support. :/

comment:9 in reply to: ↑ 8 Changed 11 years ago by kj17x0

Replying to charles:

kj17x0, I've looked over the log files and they don't really tell me anything about the crash. I would love to help you more on this but the first step is that you'll need to find a DD-WRT person to help you with DD-WRT tech support. :/

Ok i will c wat i can do

Changed 11 years ago by kj17x0

comment:10 Changed 11 years ago by kj17x0

I ran transmission with transmission-daemon --logfile /mnt/btlog --log-debug. I looked at the file and found three errors. 2 about upnp and 1 about readnatpmpresponseorretry failed. There is also another error with dht in the syslog. Dont know if the new log will help. I searched all over the web and found nothing.

Thx

comment:11 follow-up: Changed 11 years ago by charles

I appreciate this, but the port mapping errors don't have anything to do with the crash. The next step is to find a DD-WRT person to help you with DD-WRT tech support.

comment:12 in reply to: ↑ 11 Changed 11 years ago by kj17x0

Replying to charles:

I appreciate this, but the port mapping errors don't have anything to do with the crash. The next step is to find a DD-WRT person to help you with DD-WRT tech support.

I have posted a thread in the ddwrt forum three days ago but no one have replied. Is there a chance that i can solve the problem by compiling transmission from source myself? Can it be a compiler bug?

Thx

comment:13 follow-up: Changed 11 years ago by charles

I'm sorry, but I don't know how to building Transmission on DD-WRT. Are there no DD-WRT experts available to help?

comment:14 in reply to: ↑ 13 Changed 11 years ago by kj17x0

Replying to charles:

I'm sorry, but I don't know how to building Transmission on DD-WRT. Are there no DD-WRT experts available to help?

*sign* I posted a thread in both ddwrt and openwrt forum four days ago but not a single response. I guess i just have to try things out and maybe wait for a new thread or post about the problem? Thx for the help anyways

comment:15 follow-up: Changed 11 years ago by jordan

Any news to report?

comment:16 in reply to: ↑ 15 Changed 11 years ago by kj17x0

Replying to jordan:

Any news to report?

not really. still trying to figure out the cause.

comment:17 Changed 11 years ago by jordan

  • Resolution set to invalid
  • Status changed from new to closed

I'm going to close this ticket for now because this doesn't appear to be a Transmission issue. Lots of people are using transmission-daemon on DD-WRT, and if it crashed on every torrent this ticket would have 300 comments from unhappy DD-WRT users.

This is probably an issue with the system you're running, or a build issue with wherever you got your copy of transmission-daemon from. If there's anything that I can do to help you, or if you think this is a transmission-daemon bug, please reopen this ticket with more information. I'd be happy to help if I can.

Note: See TracTickets for help on using tickets.