Opened 11 years ago

Closed 11 years ago

Last modified 11 years ago

#3787 closed Bug (fixed)

"No Announce Scheduled" tracker error

Reported by: charles Owned by: charles
Priority: High Milestone: 2.13
Component: libtransmission Version: 2.12
Severity: Normal Keywords: backport-2.0x
Cc:

Description (last modified by charles)

Forum thread: https://forum.transmissionbt.com/viewtopic.php?f=4&t=9809&start=15

It seems to be caused by a call to "tier->announceAt = tr_time()" during startup when tr_time's cache of time(NULL) hasn't been initialized yet.

We should set tr_time()'s cache immediately on startup in tr_sessionInit().

Change History (5)

comment:1 Changed 11 years ago by charles

  • Status changed from new to assigned

Change made in r11449

comment:2 Changed 11 years ago by charles

  • Description modified (diff)
  • Resolution set to fixed
  • Status changed from assigned to closed

Fix confirmed by coreymon77.

comment:3 Changed 11 years ago by charles

  • Keywords backport-2.0x added

comment:4 Changed 11 years ago by charles

  • Priority changed from Normal to High

comment:5 Changed 11 years ago by charles

backported to 2.0x by r11467

Note: See TracTickets for help on using tickets.