Opened 11 years ago

Closed 11 years ago

#3791 closed Bug (duplicate)

shutdown does not happen on receipt of a kill signal.

Reported by: transmissiongear Owned by: charles
Priority: Normal Milestone: None Set
Component: GTK+ Client Version: 2.12
Severity: Normal Keywords: shutdown
Cc:

Description

transmission-gtk 2.12 does not shutdown correctly when sent a "kill" signal.

After shutdown in this manner, all data is re-verified on next start up. This does not happen if shutdown occurs using file-quit from the menu.

This is used if the computer is shutdown, so this will also presumably result in the need to fully re-verify part-downloaded torrents next time it is run.

Emergency shutdown should be used only on receipt of a -9 signal, kill -9, not the normal sighup one.

To reproduce: 
1) start transmission, you need one or more sizeable part-downloaed torrent. 
Check that the torrent is not "verifying", if it is wait until completed. 
2) File-Quit. 
3) restart, notice that there is no verifying local data. This is as it should be. 
4) do ps -elf | grep transmission-gtk to get the pid.
5) do kill pid where pid is the pid number. 
6) restart transmission-gtk and notice that the local data is now being verified. 
7) I assume that this means that exit did not occur correctly in response 
to the kill. 

Change History (5)

comment:1 Changed 11 years ago by charles

  • Component changed from Transmission to GTK+ Client
  • Owner set to charles

comment:2 Changed 11 years ago by transmissiongear

See also 2454. "gtk client handles SIGINT (ctrl-c) oddly" I quote "At any rate, a first SIGINT should attempt an orderly shutdown as if the "Exit" menu option were clicked." This is all I am asking for here really, but 2454 has been closed..

comment:3 Changed 11 years ago by livings124

  • Summary changed from suhutdown does not happen on receipt of a kill signall. to shutdown does not happen on receipt of a kill signall.

comment:4 Changed 11 years ago by charles

  • Summary changed from shutdown does not happen on receipt of a kill signall. to shutdown does not happen on receipt of a kill signal.

comment:5 Changed 11 years ago by charles

  • Resolution set to duplicate
  • Status changed from new to closed

This issue is mooted by #2955 ... we're no longer saving the same kind of information in the .resume file anymore, so the timing issues are moot.

Closing this ticket as a duplicate of #2955.

Note: See TracTickets for help on using tickets.