Opened 10 years ago

Closed 8 years ago

#3807 closed Enhancement (wontfix)

support local filesystem charset

Reported by: starmoon Owned by:
Priority: Normal Milestone: None Set
Component: Transmission Version: 2.12
Severity: Normal Keywords:
Cc:

Description

I HAVE TO use local charsets insdeed of UTF-8 encoding. This may implemented by hooking any local file open/directory search function. Done by iconv_open or so functions. local charset convertion should be done on message log too.

Thanks, looking forward for develop team responese.

currently I do filename translation to local charset by using a "finish script".

but when file and/or directory was renamed. no future seeding is possiable. so i just stop seeding by sending back a stop command.

#! /bin/sh
# onfinish.sh by starmoon
LOGFILE=/root/tr.log

#echo `date "+[%F %T]"` $TR_TORRENT_DIR $TR_TORRENT_HASH  $TR_TORRENT_NAME >> $LOGFILE

PWD=`pwd`
cd "$TR_TORRENT_DIR"

if [ -e "$TR_TORRENT_NAME" ]; then
NAME=$(echo $TR_TORRENT_NAME | iconv -f utf8 -t gb18030)
echo -n `date "+[%F %T]"` $TR_TORRENT_HASH $NAME >> $LOGFILE
chown -R --reference=. "$TR_TORRENT_NAME"

CNT=$(convmv -f utf8 -t cp936 -r --notest "$TR_TORRENT_NAME" | wc -l)
if [ $CNT -gt 0 ]; then
   echo ' *' >> $LOGFILE
   transmission-remote -n admin:pass -t $TR_TORRENT_ID --stop &
else
   echo >> $LOGFILE
fi
fi

cd $PWD

but this preventing this torrent from continue seeding.

Change History (8)

comment:1 Changed 10 years ago by livings124

  • Milestone changed from 2.20 to None Set

comment:2 Changed 10 years ago by charles

  • Resolution set to duplicate
  • Status changed from new to closed

This sounds like a duplicate of #1220 to me. Please reopen this ticket if I've misunderstood the issue.

comment:3 Changed 10 years ago by starmoon

  • Resolution duplicate deleted
  • Status changed from closed to reopened

To Charles: These two tickets are not same at all. #1220 only do a relocate of top filename,and this ticket affects all filenames in torrent. But no static mapping required. Filenames be dynamicly converted in file I/O operations acording to local_charset settings.

comment:4 Changed 10 years ago by starmoon

is there any progress on this?

comment:5 Changed 10 years ago by charles

Not really. I am probably not the best person to write or test this patch.

comment:6 Changed 10 years ago by jordan

Ticket #3633 has been closed as a duplicate of this ticket.

comment:7 Changed 10 years ago by jch

Shouldn't you be running in a UTF-8 locale by now? It's 2011, you know?

--jch

comment:8 Changed 8 years ago by jordan

  • Resolution set to wontfix
  • Status changed from reopened to closed

I agree with jch that it's reasonable to expect UTF-8 support.

Also, two years have passed and there doesn't seem to be any other demand for this.

Closing as a wontfix.

Note: See TracTickets for help on using tickets.