Opened 8 years ago

Closed 7 years ago

#3820 closed Bug (fixed)

Web UI flicking to selection

Reported by: monkeyman23555 Owned by: fx
Priority: Lowest Milestone: 2.30
Component: Web Client Version: 2.12
Severity: Trivial Keywords: Web, UI, Flicking, Selection
Cc:

Description

Hello everyone

This is a trivial bug, I am simply making a ticket to ensure that it has been noted. (If the web UI is replaced by something other than clutch this will probably not be accurate anymore.)

When you select a torrent in the Web UI and scroll to a different location so that the selected torrent is out of view, then when the refresh happens the view flicks back to the selected torrent. This works in both normal and compact modes.

I tested it with both Firefox and Safari form my headless NAS running 2.12 and my mac transmission running 2.13.

Attachments (1)

transmission.js.patch (317 bytes) - added by bulljit 7 years ago.

Download all attachments as: .zip

Change History (12)

comment:1 Changed 7 years ago by jordan

This is unlikely to be fixed unless someone submits a patch.

The web client currently has no maintainer, and is getting by on submitted patches.

comment:2 Changed 7 years ago by fx

  • Owner changed from kjg to fx

comment:3 Changed 7 years ago by fx

Looks like its the scrollToElement function, Commenting line number transmission.js:461 seems to stop it without any adverse effects, Makes me wonder what is the purpose of that function...

This is where i made the change:

selectElement: function( e, doUpdate ) {
    e.addClass('selected');
    //this.scrollToElement( e );
    if( doUpdate )
        this.selectionChanged( );
},

comment:4 Changed 7 years ago by jordan

I think that line was to ensure that the gui scrolls to any torrent that is selected by the app rather than by the user. (Any torrent seleced by the user will already be onscreen.)

However I can't find any code path for the selection-by-app case. If there was one, I don't see it now.

So maybe that line should be removed? I don't see any downside to removing it and getting wider user testing on this theory.

comment:6 Changed 7 years ago by livings124

  • Milestone changed from None Set to 2.30

comment:7 Changed 7 years ago by livings124

  • Resolution set to fixed
  • Status changed from new to closed

comment:8 Changed 7 years ago by Tenzer

  • Resolution fixed deleted
  • Status changed from closed to reopened

I think the offending line was intended for users navigating the web interface with the keyboard, since it makes the list scroll up or down when using the arrow keys on the keyboard to navigate with. With this line commented out this will no longer happen, and make it impossible to see any torrents not on in the current view, by only using the keyboard.

I don't know what the preference is here, and how highly the keyboard navigation is prioritized, but I am reopening this ticket to allow people here to find out.

Personally I haven't had issues with the flickering the issue originally concerned, so I would prefer if the line stayed in as in Transmission 2.22.

Changed 7 years ago by bulljit

comment:9 Changed 7 years ago by bulljit

@Tenzer

Try the attached patch on the latest version of the transmission.js (v2.30b4). It simply adds line 578:

tr.scrollToElement(tr._rows[i]); // see https://trac.transmissionbt.com/ticket/3820

This should resolve your keyboard navigation problem seen with r12342.

BTW the "flickering" issue is only seen when you advance the scrollbar past the currently selected torrent (using your mouse). I assume you only use your keyboard for navigation and therefore never elicited this bug.

comment:10 Changed 7 years ago by jordan

looks right to me. Thanks buljit, thanks Tenzer :)

comment:11 Changed 7 years ago by jordan

  • Resolution set to fixed
  • Status changed from reopened to closed

r12430: apply patch from buljit to fix keyboard navigation regression

Note: See TracTickets for help on using tickets.