Opened 11 years ago

Closed 11 years ago

Last modified 11 years ago

#3826 closed Bug (fixed)

all data fails its checksum test in uClibc 0.9.27

Reported by: charles Owned by: charles
Priority: Normal Milestone: 2.20
Component: libtransmission Version: 1.80
Severity: Major Keywords: backport-2.0x backport-2.1x
Cc:

Description (last modified by charles)

https://forum.transmissionbt.com/viewtopic.php?f=2&t=10896

Yes !!! This is it. pread() and pwrite() is broken in uClibc 0.9.27. Without it transmission works perfect.

That link's from 2003 though. Are you sure this is still a uClibc issue?

Also, I see 0.9.31 has been available since April. Does upgrading uClibc solve the issue?

This bug is present in 0.9.27 version. And 0.9.27 is very old version (released in Jan-2005). Upgrading is not possible, because root fs hardcoded in AzBox?'s ROM as CRAMFS. Reflashing of ROM is not a trivial operation. But, IMHO, adding checks for MIPS and uCLibc in configure to not use pread()/pwrite() if fully solves this issue.

Change History (7)

comment:1 Changed 11 years ago by charles

  • Status changed from new to assigned
  • Version changed from 2.13 to 1.80

comment:2 Changed 11 years ago by charles

  • Resolution set to fixed
  • Status changed from assigned to closed

fixed in trunk by r11530.

It would be nice to do this conditionally based on the uClibc version number, rather than unconditionally like this, but I didn't see the fix mentioned anywhere, so I don't know what version to test for. :(

comment:3 Changed 11 years ago by charles

  • Description modified (diff)

comment:4 Changed 11 years ago by charles

  • Summary changed from don't use pread() or pwrite() on uclibc to all data fails its checksum test on uC libc 0.9.27

comment:5 Changed 11 years ago by charles

  • Summary changed from all data fails its checksum test on uC libc 0.9.27 to all data fails its checksum test in uClibc 0.9.27

comment:6 Changed 11 years ago by charles

r11531: refinement of r11530 based on research by iz0bbz to find which version of uClibc added a fix.

comment:7 Changed 11 years ago by charles

Ticket #2858 has been closed as a duplicate of this ticket.

Note: See TracTickets for help on using tickets.