Opened 11 years ago

Closed 11 years ago

#3831 closed Bug (invalid)

Invalid UTF-8 string passed to pango_layout_set_text()

Reported by: tforsman Owned by: charles
Priority: Normal Milestone: None Set
Component: GTK+ Client Version: 2.13
Severity: Normal Keywords: Pango, gdk, utf-8
Cc:

Description

Everytime i open Transmission from tray to view it, i get alot of warnings/errors in xsession-errors file in Linux.

(transmission-gtk:1548): Pango-WARNING : Invalid UTF-8 string passed to pango_layout_set_text()

(transmission-gtk:1548): Gdk-CRITICAL : IAgdk_window_get_root_coords: assertion `GDK_IS_WINDOW (window)' failed

Change History (4)

comment:1 Changed 11 years ago by charles

Does this happen even if you have no torrents visible in the main window's list?

If it's triggered by a certain torrent, could you try filtering torrents by name, then hiding/restoring from the tray, to figure out which torrent is causing the problem?

comment:2 Changed 11 years ago by charles

  • Component changed from Transmission to GTK+ Client
  • Owner set to charles

comment:3 Changed 11 years ago by tforsman

Yes, i even removed all torrents inside Transmission and restarted it. same issue.

Also seems to be specified to a single gtk theme too. I get this problem when using: https://projects.kde.org/projects/playground/artwork/oxygen-gtk

But if i use something else, the problem isnt there anymore.

comment:4 Changed 11 years ago by jordan

  • Resolution set to invalid
  • Status changed from new to closed

If that's the case, this sounds a lot like an oxygen-gtk bug rather than a Transmission bug.

Please report this upstream to the oxygen-gtk developers at https://bugs.kde.org/

Thank you!

Note: See TracTickets for help on using tickets.