Opened 11 years ago

Closed 11 years ago

Last modified 10 years ago

#3832 closed Bug (invalid)

Transmission is using two times the upload limit

Reported by: 133794m3r Owned by: charles
Priority: Normal Milestone: None Set
Component: GTK+ Client Version: 2.03
Severity: Normal Keywords:
Cc:

Description

As stated transmission is using two times the upload bandwith as it's supposed to. I just went and got the pioneer one series and i was wondering why it was so slow once i started it up. It is limited to 25KB/s but it uses 45-55KB/s and seems to do a little more than two times it no matter what i've done. Peer limit per torrent 15, overall 95, but i don't see an option to reduce active files but right now it's only 7 active torrents. I've closed all other applications that _might_ be using the internet sans transmission and it seems to be the culprit. I'm going to go attempt to build 2.13 to see how it works and i hope that the issue isn't present there.

Change History (6)

comment:1 Changed 11 years ago by 133794m3r

  • Component changed from Transmission to GTK+ Client
  • Owner set to charles

i just built 2.13 and it's still doing the same thing. I think it may be something within transmission itself. So it's in there in 2.03 and 2.13( i just built it from source) and it's still using 2x it's upper limit according to the system monitor transmission is using only 26-27KB/s

comment:2 Changed 11 years ago by charles

This issue has been reported before on the Ubuntu bug tracker. In that ticket I did considerable research showing how well (or how poorly) the different BitTorrent? clients stick to their speed limits.

Each screenshot shows a different bittorrent client downloading the same Ubuntu ISO torrent with speed capped at 15 KB/s both ways, next to a gnome-system-monitor showing overall network use. As a visual aid I've added a horizontal green line showing the "ideal" of where a constant 15 KB/s would lie on each g-s-m network graph.

My conclusion then was that there is a lot of fluctuation inherent in the system, and that all bittorrent clients are affected by it. Even so, Transmission seemed to be the least affected by it.

So if there's a regression here, I'll need some more information to go with the bug report. Could you run your system through a similar benchmark?

comment:4 Changed 11 years ago by jordan

We'd like to figure out what's causing this bug for you, but we haven't heard back from you in a while. Could you please provide the requested information? Thanks!

comment:5 Changed 11 years ago by jordan

  • Resolution set to invalid
  • Status changed from new to closed

We are closing this bug report because it lacks the information we need to investigate the problem, as described in the previous comments. Please reopen it if you can give us the missing information, and don't hesitate to submit bug reports in the future. Thanks again!

comment:6 Changed 10 years ago by jordan

Ticket #4593 has been closed as a duplicate of this ticket.

Note: See TracTickets for help on using tickets.