Opened 10 years ago

Closed 10 years ago

#3853 closed Bug (fixed)

r11524 broke adding torrents via the web client

Reported by: mactijn Owned by: livings124
Priority: Normal Milestone:
Component: Transmission Version: 2.13+
Severity: Normal Keywords:
Cc: tom@…

Description (last modified by charles)

Details

  • Browser: Chrome 8.0.552.231
  • Transmission: trunk, 2.13+ (changeset #11603)

Changeset r11524, meant to make the API URL more configurable, introduced a bug regarding uploading files from the web interface.

Browsing through libtransmission/rpc-server.c it looks like the handle_upload() statement is moved to after the check for a valid session id, while the web interface doesn't add the header to the form submission (seems to me that's hard to impossible).

A suggested solution would be to move it back to before the session id check.

Attachments (1)

upload.patch (824 bytes) - added by mactijn 10 years ago.

Download all attachments as: .zip

Change History (10)

comment:1 Changed 10 years ago by gunzip

i'm seeing the same regression with Firefox/3.6.10 and transmission-daemon 2.13+ (11564)

comment:2 Changed 10 years ago by charles

  • Description modified (diff)
  • Owner changed from charles to werehamster

comment:3 Changed 10 years ago by charles

  • Cc tom@… added

comment:4 Changed 10 years ago by charles

adding wereHamster to the CC list

comment:5 Changed 10 years ago by livings124

  • Summary changed from since commit #11524 uploads from the webinterface are broken to since commit r11524 uploads from the webinterface are broken

comment:6 Changed 10 years ago by charles

  • Summary changed from since commit r11524 uploads from the webinterface are broken to r11524 broke adding torrents via the web client

Changed 10 years ago by mactijn

comment:7 Changed 10 years ago by mactijn

upload.patch fixes the problem introduced in r11524 by moving the execution of handle_upload() to before the REQUIRE_SESSION_ID ifdef.

comment:8 Changed 10 years ago by livings124

  • Owner changed from werehamster to livings124
  • Status changed from new to assigned

comment:9 Changed 10 years ago by livings124

  • Component changed from libtransmission to Transmission
  • Milestone None Set deleted
  • Resolution set to fixed
  • Status changed from assigned to closed

Thanks! r11615

Note: See TracTickets for help on using tickets.