Opened 11 years ago

Closed 11 years ago

#3874 closed Bug (worksforme)

Seeding metadata for magnet links

Reported by: eurekafag Owned by:
Priority: Normal Milestone: None Set
Component: Transmission Version: 2.03
Severity: Normal Keywords: magnet, upload, seed
Cc:

Description

Looks like transmission can't seed metadata for peers which have only magnet link and no torrent file. I tried the following scheme: two notebooks with Debian (transmission 2.03, 11030) and Ubuntu (1.93, 10621). Both handle magnet links fine, I tried several magnet-linked torrents on them (DHT works perfectly, too, I removed trackers from the link and it found peers, downloaded metadata and started downloading torrent, ports are open on both, checked in options pressing the button). Then I created a new torrent on one of them and started seeding it. Copied magnet-link. Added the magnet on another. Waited for about an hour without success. Then tried to create another torrent on the second notebook and added the magnet for it to the first with the same result. I think that transmission can only download metadata but not upload it to other clients and it's very bad. rTorrent can't upload it, too. AFAIK, only uTorrent can, but I didn't check it though it always present on popular torrents and seeds metadata for us. It'd be very nice for transmission to do the same because then I could create torrents for people and give them only the magnet link. For now if I'm the only seed for the particular torrent no one can get the actual metadata from me and can't start downloading.

I also think such halfed support of magnet links should be noticed somewhere. Like: "You can download torrents using magnet links but can't start new seeding without help of other clients which should have the full torrent file".

Change History (3)

comment:1 Changed 11 years ago by jordan

I also think such halfed support of magnet links should be noticed somewhere. Like: "You can download torrents using magnet links but can't start new seeding without help of other clients which should have the full torrent file".

If Transmission can't seed metadata it's due to a bug in Transmission, not by design.

comment:2 Changed 11 years ago by eurekafag

Yes, but I've never seen any client seeding metadata other than uTorrent. Looks like nobody thinks about this feature so magnets are useless if there are no uTorrent users on a particular torrent seed.

comment:3 Changed 11 years ago by jordan

  • Resolution set to worksforme
  • Status changed from new to closed

I just tested this out and was able to seed metadata, then data, in a swarm containing only two Transmission 2.20 beta 1 peers. Seems to be working here.

It's possible that there's something wrong in the older version of Transmission, but since it's confirmed working now I'm not going to dig into it.

Note: See TracTickets for help on using tickets.