Opened 11 years ago

Closed 11 years ago

#3885 closed Bug (duplicate)

Transmission leaks file descriptors after some suspend/resume cycles

Reported by: walmis Owned by:
Priority: Normal Milestone: None Set
Component: Transmission Version: 2.13
Severity: Normal Keywords:
Cc:

Description

I'm always running transmission in the background with suspend-resume cycles in between, and after some time, mostly on the second day transmission starts using 100% cpu and when i open preferences dialog it displays "too many open files" error.

lsof yield these and similar lines:

transmiss 6418 walmis 2038u  sock                0,6        0t0    456726 can't identify protocol
transmiss 6418 walmis 2039u  sock                0,6        0t0    456733 can't identify protocol
transmiss 6418 walmis 2040u  sock                0,6        0t0    456785 can't identify protocol
transmiss 6418 walmis 2041u  sock                0,6        0t0    456755 can't identify protocol
transmiss 6418 walmis 2042u  sock                0,6        0t0  16865496 can't identify protocol
transmiss 6418 walmis 2043u  sock                0,6        0t0  16865480 can't identify protocol
transmiss 6418 walmis 2044u  sock                0,6        0t0    456753 can't identify protocol
transmiss 6418 walmis 2045u  sock                0,6        0t0  16865485 can't identify protocol
transmiss 6418 walmis 2046u  sock                0,6        0t0    456797 can't identify protocol
transmiss 6418 walmis 2047u  sock                0,6        0t0    456805 can't identify protocol
lsof -n -p $(pidof transmission) | wc -l
2201

On my other server box which is constantly on, I do not observe this problem. This leads me to believe that the suspend and resume cycles causes this leak, for some reason transmission does not close the invalid network sockets after resume.

My OS is Ubuntu 10.10. Tried the latest transmission, and the one that ships with ubuntu, with the same results.

Change History (1)

comment:1 Changed 11 years ago by jordan

  • Resolution set to duplicate
  • Status changed from new to closed

walmis, thanks for reporting this issue. I think this is a duplicate of #3504, which is fixed in trunk.

Note: See TracTickets for help on using tickets.