Opened 11 years ago

Closed 11 years ago

#3888 closed Bug (duplicate)

RPC move blocks any subsequent RPC calls until completion

Reported by: oh_noes Owned by:
Priority: Normal Milestone: None Set
Component: libtransmission Version: 2.13
Severity: Normal Keywords:
Cc:

Description

Is this expected? When I move a torrent RPC locks up and doesn't respond to any future RPC connections.

This affects both localhost and remote RPC. Below test shows localhost. This is an issue because sometime if a user moves a large torrent on a slow machine, it could take a while.

Is this expected behavior or a Solaris specific bug? Please let me know (including instructions) if gdb is wanted.

Solaris 10 Update 9, x86.

Is this standard behaviour?

{{{
[SERVER:/export/home/USER][USER]# /usr/local/transmission/bin/transmission-remote -l | grep MY_TORRENT$
  35   100%  925.6 MiB  Done         8.0     0.0   0.00  Seeding      MY_TORRENT
[SERVER:/export/home/USER][USER]# time /usr/local/transmission/bin/transmission-remote -t 35 --move /data/Sort &
[1] 24176
[SERVER:/export/home/USER][USER]# /usr/local/transmission/bin/transmission-remote -l | grep MY_TORRENT$
http://localhost:9091/transmission/rpc/ responded: "success"

real    0m39.560s
user    0m0.005s
sys     0m0.006s
  35   100%  925.6 MiB  Done         3.0     0.0   0.00  Seeding      MY_TORRENTs
[1]+  Done                    time transmission-remote -t 35 --move /data/Sort
[SERVER:/export/home/USER][USER]# 
}}}

As you can see, the --list locks until the original move finishes.

Change History (2)

comment:1 Changed 11 years ago by oh_noes

  • Version changed from 2.13 to 2.13+

transmission-daemon 2.13+ (11666)

comment:2 Changed 11 years ago by jordan

  • Component changed from Transmission to libtransmission
  • Resolution set to duplicate
  • Status changed from new to closed
  • Version changed from 2.13+ to 2.13

Moving back to 2.13 because this isn't new behavior in the nightlies.

Yes, this is -- unfortunately -- expected.

Closing this ticket as a duplicate of #1753.

Note: See TracTickets for help on using tickets.