Opened 11 years ago

Closed 11 years ago

#3890 closed Bug (invalid)

uninitialized memory warning in bencode serialization

Reported by: jordan Owned by: jordan
Priority: Normal Milestone: None Set
Component: libtransmission Version: 2.13
Severity: Minor Keywords:
Cc:

Description (last modified by jordan)

==26523== Syscall param writev(vector[...]) points to uninitialised byte(s)
==26523==    at 0x4BCD176: writev (writev.c:56)
==26523==    by 0x472C03E: evbuffer_write_iovec (buffer.c:2220)
==26523==    by 0x472E7A4: evbuffer_write_atmost (buffer.c:2298)
==26523==    by 0x472E84B: evbuffer_write (buffer.c:2324)
==26523==    by 0x808F64A: tr_bencToFile (bencode.c:1691)
==26523==    by 0x80D3D05: tr_torrentSaveResume (resume.c:536)
==26523==    by 0x80ADDFB: tr_torrentSave (torrent.c:1697)
==26523==    by 0x80A3B0C: onSaveTimer (session.c:492)
==26523==    by 0x4728667: event_base_loop (event.c:1287)
==26523==    by 0x4729344: event_base_dispatch (event.c:1382)
==26523==    by 0x80B471B: libeventThreadFunc (trevent.c:245)
==26523==    by 0x809AC51: ThreadFunc (platform.c:118)
==26523==  Address 0x7b1f8cc is 1,212 bytes inside a block of size 8,192 alloc'd
==26523==    at 0x4023F50: malloc (vg_replace_malloc.c:236)
==26523==    by 0x4724B67: event_mm_malloc_ (event.c:2569)
==26523==    by 0x472A655: evbuffer_chain_new (buffer.c:168)
==26523==    by 0x472CBA7: evbuffer_expand_singlechain (buffer.c:292)
==26523==    by 0x472CEC1: evbuffer_expand (buffer.c:1888)
==26523==    by 0x808F4A0: tr_bencToBuf (bencode.c:1603)
==26523==    by 0x808F628: tr_bencToFile (bencode.c:1688)
==26523==    by 0x80D3D05: tr_torrentSaveResume (resume.c:536)
==26523==    by 0x80ADDFB: tr_torrentSave (torrent.c:1697)
==26523==    by 0x80A3B0C: onSaveTimer (session.c:492)
==26523==    by 0x4728667: event_base_loop (event.c:1287)
==26523==    by 0x4729344: event_base_dispatch (event.c:1382)
==26523== 
==26523== 
==26523== ---- Attach to debugger ? --- [Return/N/n/Y/y/C/c] ----

Change History (6)

comment:1 Changed 11 years ago by jordan

  • Description modified (diff)

comment:2 Changed 11 years ago by x190

Might this be related to the "Result too large" forum thread?

https://forum.transmissionbt.com/viewtopic.php?f=2&t=10985&start=30#p52083

comment:3 Changed 11 years ago by jordan

I'm not able to trigger this behavior again.

comment:4 Changed 11 years ago by jordan

Three more days of valgrind and this hasn't come back...

comment:5 Changed 11 years ago by jordan

x190, no I don't think this is related to "result too large"...

comment:6 Changed 11 years ago by jordan

  • Resolution set to invalid
  • Status changed from new to closed

It still hasn't come back.

I don't like the idea of closing a bug without knowing something about its root cause, but since this bug is not reproducable there doesn't seem to be any point in leaving it open either.

Note: See TracTickets for help on using tickets.