Opened 11 years ago

Closed 11 years ago

Last modified 11 years ago

#3938 closed Bug (fixed)

The config directory isn't created by the Qt client

Reported by: luksan Owned by: luksan
Priority: Normal Milestone: 2.20
Component: Qt Client Version: 2.13
Severity: Normal Keywords:
Cc:

Description

If the default configuration directory doesn't exist at startup transmission-qt will fail to save the preferences file.

A patch to fix this is attached. The directory is only created if no config dir was specified on the command line.

Attachments (1)

0001-Create-the-default-config-directory-if-it-doesn-t-ex.patch (1005 bytes) - added by luksan 11 years ago.

Download all attachments as: .zip

Change History (6)

comment:1 Changed 11 years ago by jordan

  • Component changed from Transmission to Qt Client
  • Milestone changed from None Set to 2.20
  • Owner set to luksan

comment:2 Changed 11 years ago by jordan

  • Resolution set to fixed
  • Status changed from new to closed

r11755 qt/app.cc:

(trunk qt) #3938 "The default config directory isn't created by the Qt client" -- fixed.

Summary says it all. Patch by luksan with minor formatting changes (and, no doubt, a new bug) by me.

comment:3 in reply to: ↑ description Changed 11 years ago by jordan

Replying to luksan:

The directory is only created if no config dir was specified on the command line.

Actually its seems like it would be better to create the config dir even if a custom one is passed in via the command line -- that's what transmission-daemon and transmission-gtk do, too.

Fixed in r11758

comment:4 Changed 11 years ago by jordan

Ticket #3503 has been closed as a duplicate of this ticket.

comment:5 Changed 11 years ago by jordan

  • Summary changed from The default config directory isn't created by the Qt client to The config directory isn't created by the Qt client
Note: See TracTickets for help on using tickets.