Opened 11 years ago

Closed 11 years ago

Last modified 11 years ago

#3964 closed Bug (fixed)

transmission-edit replace option cuts off strings

Reported by: ijuxda Owned by: jordan
Priority: Normal Milestone: 2.20
Component: Utils Version: 2.13
Severity: Normal Keywords: transmission-edit replace substring cutoff
Cc:

Description

Instead of replacing just the matching substring, the rest of the original string after the match is lost. E.g.

$ transmission-edit -r ubun foo ubuntu.torrent
        Replaced in "announce": "http://torrent.ubuntu.com:6969/announce" --> "http://torrent.foo"
        Replaced in "announce-list" tier 1: "http://torrent.ubuntu.com:6969/announce" --> "http://torrent.foo"
        Replaced in "announce-list" tier 2: "http://ipv6.torrent.ubuntu.com:6969/announce" --> "http://ipv6.torrent.foo"
Changed 1 files

Change History (4)

comment:1 Changed 11 years ago by ijuxda

  • Keywords transmission-edit added; tranmission-edit removed

comment:2 Changed 11 years ago by jordan

  • Status changed from new to assigned
  • Version changed from 2.13+ to 2.13

Changing version number from 2.13+ to 2.13, since this isn't a post-2.13 regression.

(Actually it seems to be a 2.10 bug, but since that's not always easy to determine in other tickets, the team's convention is to use the closest release version that it was reported against)

comment:3 Changed 11 years ago by jordan

  • Resolution set to fixed
  • Status changed from assigned to closed

jordan * r11791 utils/edit.c:

(trunk utils) #3964 "transmission-edit replace option cuts off strings" -- fixed.

The trailing text after the last substring match wasn't being retained.

comment:4 Changed 11 years ago by jordan

  • Milestone changed from None Set to 2.20
Note: See TracTickets for help on using tickets.