Opened 11 years ago

Closed 11 years ago

Last modified 11 years ago

#3976 closed Enhancement (invalid)

Better support for firewalls/anti-virus during update process

Reported by: Renara Owned by: livings124
Priority: Low Milestone: None Set
Component: Mac Client Version: 2.13
Severity: Minor Keywords:
Cc:

Description

This is a fairly minor but infrequently very annoying... well not a bug exactly which is why I'm listing it as an enhancement.

Basically, I run Intego VirusBarrier? on Mac OS X, and it has an outgoing firewall capability, as do a few other anti-virus/firewall packages on OS X and other systems (though I can't speak for those). Now, naturally I've allowed outgoing connections for Transmission, however, during the update process a duplicate version of Transmission exists, which off course firewall software doesn't like one bit, in my case it can result in various annoying warnings and so-on.

I believe the reason for this is that Transmission is copying the new version of the application into place /before/ the existing one has closed down. The result is that the active Transmission application is moved to .Trash and isn't recognised as the application that has permission to create outgoing connections.

The proposal therefore is that when Transmission downloads an update that it be placed somewhere temporarily, and the running application, upon being told to upgrade, will close itself down, and as its /last/ action will move the new application into place and move itself into .Trash. This way, the update process should then be better supported by firewall software, anti-virus and the like.

The only potential side-effect of this is if Transmission crashes while shutting down for an update, in this case it may make sense for Transmission to check for a downloaded update when launched as well, so it can apply the update and relaunch right away if the update failed the first time round.

Change History (3)

comment:1 Changed 11 years ago by livings124

  • Resolution set to invalid
  • Status changed from new to closed

Auto-update is handled by Sparke, so best to file this upstream. http://sparkle.andymatuschak.org/

comment:2 Changed 11 years ago by Renara

Ooops, thanks for letting me know! I'll go poke them instead then, thanks for the link!

comment:3 Changed 11 years ago by Renara

Just wanted to let you know that the issue seems to be seeing progress under a ticket on their bug-tracker here: https://bugs.launchpad.net/sparkle/+bug/534625

I'll follow its progress and re-open this issue once Sparkle is able to support any necessary changes.

Note: See TracTickets for help on using tickets.