Opened 11 years ago

Closed 11 years ago

#4000 closed Bug (duplicate)

Transmission 'Dark Bits' Clogging teh Intertubes

Reported by: Lacrocivious Owned by:
Priority: Normal Milestone: None Set
Component: Transmission Version: 2.20
Severity: Normal Keywords: dark bits intertubes accretion purge needinfo
Cc:

Description

Researchers at IETF, responding recently to widespread complaints of inexplicable slowdowns and blockages along Intertubes pathways, report having identified massive accumulations of 'dark bits', previously unknown despite having grown to as much as fifteen percent of all Intertubes traffic. These dark bits are persistent, difficult or impossible to remove, and occlude vital Intertubes pathways in mysterious fashion. Little is known about dark bits except for their source, which has been conclusively identified as Transmission.

Specifically, dark bits are created when Transmission users deselect portions (generally, files) of a torrent. Because torrent pieces frequently include parts of more than one file, any portion of a piece which is part of an unwanted, deselected file is transformed by Transmission into a variably sized mass of dark bits. These dark bits are thus 'orphaned' and left to drift aimlessly through the Intertubes, colliding with and adhering to other dark bits until they accrete sufficient mass to attach themselves to Intertube walls. These accretions constrict Intertubes over time, occasionally to the point of near total blockage.

Urgent action is required to correct Transmission so that it does not create any more dark bits. If possible, Transmission should also make every effort to identify and purge the Intertubes of dark bits accumulations and blockages, thus improving Intertubes performance globally.

Change History (4)

comment:1 Changed 11 years ago by x190

Duplicate of #850. [Hmm... #532 would keep the dark bits squirreled away in the .dat files and thus avoid clogging the intertubes.]

For reference:

http://www.datclogg.com/ http://intertubes.net/

"I think the tachyon modulation must be wrongly polarised."

Last edited 11 years ago by x190 (previous) (diff)

comment:2 follow-up: Changed 11 years ago by jordan

  • Keywords needinfo added

#532 and #850 are unrelated. This seems like it has more to do with <http://en.wikipedia.org/wiki/Bufferbloat> and should be marked as a duplicate of #1193 or #2726.

Last edited 11 years ago by jordan (previous) (diff)

comment:3 in reply to: ↑ 2 Changed 11 years ago by x190

Replying to jordan:

#532 and #850 are unrelated. This seems like it has more to do with <http://en.wikipedia.org/wiki/Bufferbloat> and should be marked as a duplicate of #1193 or #2726.

Beware the "Wrath of Grapes"! :)

comment:4 Changed 11 years ago by jordan

  • Resolution set to duplicate
  • Status changed from new to closed

Closing as a duplicate of #1193

Note: See TracTickets for help on using tickets.