Opened 10 years ago

Closed 10 years ago

#4015 closed Bug (worksforme)

transmission 1.93(ubuntu) crashes due to SIGPIPE when adding torrents via web interface

Reported by: b Owned by:
Priority: Normal Milestone: None Set
Component: Web Client Version: 1.93
Severity: Major Keywords: needinfo
Cc:

Description

Often when I add a torrent using the transmission web interface transmission will crash. Usually the torrent does actually get added since when I restart it appears. Sometimes the crash happens before the torrent is added. This does not happen all the time, but does happen regularly, and always after adding a torrent via the web interface.

I did not see transmission-dbg, transmission-common-dbg or transmission-gtk-dbg packages. Here is the GDB backtrace:

Program received signal SIGPIPE, Broken pipe. [Switching to Thread 0xb75ddb70 (LWP 27316)] 0x00484422 in kernel_vsyscall () (gdb) bt #0 0x00484422 in kernel_vsyscall () #1 0x0016bedb in write () from /lib/tls/i686/cmov/libpthread.so.0 #2 0x080b9234 in ?? () #3 0x080b93dd in ?? () #4 0x080ba98c in tr_peerIoFlush () #5 0x080b09e7 in ?? () #6 0x080b14c8 in tr_bandwidthAllocate () #7 0x080bbcf0 in ?? () #8 0x0012f274 in event_base_loop () from /usr/lib/libevent-1.4.so.2 #9 0x0012f3c9 in event_loop () from /usr/lib/libevent-1.4.so.2 #10 0x0012f3ee in event_dispatch () from /usr/lib/libevent-1.4.so.2 #11 0x080a7b6d in ?? () #12 0x080937f2 in ?? () #13 0x0016496e in start_thread () from /lib/tls/i686/cmov/libpthread.so.0 #14 0x01058a4e in clone () from /lib/tls/i686/cmov/libc.so.6

ProblemType?: Bug DistroRelease?: Ubuntu 10.04 Package: transmission (not installed) ProcVersionSignature?: Ubuntu 2.6.32-28.55-generic 2.6.32.27+drm33.12 Uname: Linux 2.6.32-28-generic i686 NonfreeKernelModules?: nvidia Architecture: i386 Date: Fri Feb 11 09:10:42 2011 InstallationMedia?: Ubuntu 9.10 "Karmic Koala" - Release i386 (20091028.2) ProcEnviron?:

LANG=en_US.UTF-8 SHELL=/bin/bash

SourcePackage?: transmission

https://bugs.launchpad.net/ubuntu/+source/transmission/+bug/717290

Change History (6)

comment:1 Changed 10 years ago by x190

See also #3985 comment:3.

Last edited 10 years ago by x190 (previous) (diff)

comment:2 Changed 10 years ago by livings124

Can you try with 2.21. 1.93 is quite old.

comment:3 Changed 10 years ago by b

I'm running a ubuntu LTS (lucid) Seems 1.93 is the newest for this distro.

I'm not going to upgrade until the next LTS release.

Is there a .deb available I can try before changing my repo settings?

comment:4 Changed 10 years ago by jordan

Program received signal SIGPIPE, Broken pipe

This is happening because of gdb, not because of Transmission. This isn't the cause of the crash.

See this for information on making gdb play nice with SIGPIPE: http://ahlamnote.blogspot.com/2006/12/gdb-ignore-sigpipe.html

comment:5 Changed 10 years ago by jordan

  • Keywords needinfo added

comment:6 Changed 10 years ago by livings124

  • Resolution set to worksforme
  • Status changed from new to closed

Please reopen with more information. There is a large chance this has been fixed within the last 9 months.

Note: See TracTickets for help on using tickets.