Opened 12 years ago

Closed 12 years ago

#402 closed Bug (worksforme)

Strange behavior in the program with a large amount of torrents (30+)

Reported by: smm298 Owned by: livings124
Priority: Normal Milestone:
Component: Mac Client Version: 0.90
Severity: Normal Keywords:
Cc:

Description

Strange behavior in the program with a large amount of torrents (30+). These behaviors range from not being able to open inspector, see icons in preferences, not being able to open preferences, not being able to add torrents, not being able to remove torrents. After any of these strange behaviors Transmission crashes seconds after. This has happened a dozen times for me, even in the last 5 days of the nightly builds. I also get this on .90. It is easily reproducible.

Attachments (1)

Transmission.crash.log (57.3 KB) - added by smm298 12 years ago.

Download all attachments as: .zip

Change History (13)

Changed 12 years ago by smm298

comment:1 follow-up: Changed 12 years ago by livings124

It might be a problem with APE. Can you disable that and see if it still occurs?

comment:2 in reply to: ↑ 1 Changed 12 years ago by smm298

Replying to livings124:

It might be a problem with APE. Can you disable that and see if it still occurs?

APE? All Peer Encryption?

comment:3 Changed 12 years ago by livings124

com.unsanity.ape 2.0 - I'm pretty sure that's Application Enhancer. Can you disable it and see if the problem persists?

comment:4 Changed 12 years ago by livings124

Also, make sure you test this in the newest version...seems you were using a prerelease 0.90

comment:5 Changed 12 years ago by charles

Even better would be to try one of the post-0.90 releases, such as r3599. [0.82+...0.90] leaked a lot of socket connections when multiple torrents were loaded, and that could cause all kinds of problems.

comment:6 Changed 12 years ago by livings124

smm298: ping

comment:7 Changed 12 years ago by smm298

Still getting this same error and crash even with .91. I removed APE also with the same outcome. I'm going to clear my crashlog and have it crash a few more times today and I'll put up the new log later tonight hopefully.

comment:8 Changed 12 years ago by livings124

  • Component changed from Transmission to OS X Interface
  • Owner changed from somebody to livings124
  • Priority changed from Highest to Normal
  • Severity changed from Critical to Normal

comment:9 Changed 12 years ago by livings124

Any time in particular where this crash occurs? Any specific action?

comment:10 Changed 12 years ago by livings124

  • Version changed from 0.82+ to 0.90

comment:11 Changed 12 years ago by livings124

smm298: ping

comment:12 Changed 12 years ago by livings124

  • Resolution set to worksforme
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.