Opened 11 years ago

Closed 11 years ago

Last modified 11 years ago

#4028 closed Bug (fixed)

IPv6 DHT broken

Reported by: jch Owned by: jch
Priority: Normal Milestone: 2.22
Component: Transmission Version: 2.21
Severity: Major Keywords:
Cc:

Description

Current head no longer appears to join the IPv6 DHT.

--jch

Change History (7)

comment:1 Changed 11 years ago by jordan

  • Milestone changed from None Set to 2.22
  • Owner set to jordan
  • Status changed from new to assigned

comment:2 Changed 11 years ago by jch

r11751 works.

comment:3 Changed 11 years ago by jch

r11752 also works. I'm bootstrapping manually, so perhaps it's the bootstrap that's broken.

comment:4 Changed 11 years ago by jch

r11891 also works when bootstrapping manually.

comment:5 Changed 11 years ago by jch

  • Owner changed from jordan to jch
  • Status changed from assigned to new

The IPv6 DHT appears to work, and it's bootstrapping fine. The issue is that one of our DHT boostrap nodes is dodgy, and our bootstrap code is not persistent enough.

--jch

comment:6 Changed 11 years ago by jch

  • Resolution set to fixed
  • Status changed from new to closed

Hopefully worked around in r11893.

comment:7 Changed 11 years ago by jordan

r12033 /branches/2.2x/libtransmission/tr-dht.c: (2.2x) backport r11893 for #4028 "IPv6 DHT broken" -- fixed by jch

Note: See TracTickets for help on using tickets.