Opened 11 years ago

Closed 11 years ago

Last modified 11 years ago

#4058 closed Bug (invalid)

current source package doesn't compile on Suse 11.2

Reported by: Astara Owned by:
Priority: Normal Milestone: None Set
Component: Transmission Version: 2.20
Severity: Critical Keywords:
Cc:

Description

I'm not sure when it broke as I seem to remember some issues about libevent before, but it appears the current version of transmission uses libevent2, which is way ahead of where the suse distro's are at.

Even 11.4 due out in March is based on the current 'FACTORY' version of 1.4.14b: http://software.opensuse.org/search?q=libevent&baseproject=openSUSE%3AFactory&lang=en&exclude_debug=true

If transmission has requirements for support libraries not included in the major distro's, perhaps transmission should include the necessary copy of 'libevent2' that it needs, since it doesn't seem to be included in, even, the next major version of suse (11.4) which isn't out yet.

Didn't the requirement use to be based on libevent 1.4.X ?

SuSE has an open build service that the transmission project could use to build & test suse versions of transmission if that's of any interest or use, though I've never had a need for such.

Change History (6)

comment:1 Changed 11 years ago by jordan

  • Resolution set to invalid
  • Status changed from new to closed

This is a distro issue, not a Transmission one. We can't control what libraries the distros ship with.

We have bundled libevent in the past; but when we did, many distros were unhappy with that due to redundant libraries taking up space and what they considered to be security issues of shipping with multiple versions of a library. So, I'm not in a hurry to repeat that experience.

I don't understand the use of "broke" here unless you mean "doesn't build." The specfile is explicit about needing libevent 2.0.10 or higher, so it's not a hidden dependency.

Bottom line, talk to your distro about upgrading its version of libevent :)

comment:2 Changed 11 years ago by jordan

Xref: #3836

comment:3 Changed 11 years ago by Astara

What distros or platforms do you build on?

Or are you basically saying you don't support working on any distro or platform?

comment:4 Changed 11 years ago by jordan

What productive goal did you have in mind when you wrote that question?

This is a distro issue, not a Transmission one. We can't control what libraries the distros ship with.

Talk to your distro about upgrading its version of libevent.

comment:5 Changed 11 years ago by Astara

What productive goal? The goal of getting it to build on any major distro without problems.

If I take samba, squid, the linux kernel and dump them on any major distro, type configure and make -- they just work!

Not so with transmission -- it's a distro issue.

That's the purpose of 'configure' -- so that it creates a makefile suitable for the distro it is running on. Your usage of configure isn't working for Ubuntu, Centos, or Suse and I was wondering what platforms it did work on?

It's not 'my' distro, which is why I asked what distro's you worked on out of the box. I can pick up one of those and work from there -- or is this supposed to be some sort of secret?

comment:6 Changed 11 years ago by jordan

Transmission 2.21 / libevent 2.0.10 will be preinstalled by default in Fedora 15, if that helps.

Note: See TracTickets for help on using tickets.