Opened 7 years ago

Closed 7 years ago

#4063 closed Bug (fixed)

Adding a tracker before last failed add causes lockup

Reported by: x190 Owned by: livings124
Priority: Normal Milestone: 2.30
Component: Mac Client Version: 2.20
Severity: Normal Keywords: add tracker, magnet links
Cc:

Description (last modified by livings124)

2/25/11 11:07:02 PM	Transmission[202]	Exception detected while handling key input.
2/25/11 11:07:02 PM	Transmission[202]	*** -[NSArray objectsAtIndexes:]: index (-1) beyond bounds (0)
2/25/11 11:07:03 PM	Transmission[202]	*** -[NSArray objectsAtIndexes:]: index (-1) beyond bounds (0)
2/25/11 11:07:35 PM	Transmission[202]	*** -[NSArray objectsAtIndexes:]: index (-1) beyond bounds (0)
2/25/11 11:08:03 PM	Transmission[202]	*** -[NSArray objectsAtIndexes:]: index (-1) beyond bounds (0)
2/25/11 11:08:06 PM	Transmission[202]	HIToolbox: ignoring exception '*** -[NSArray objectsAtIndexes:]: index (-1) beyond bounds (0)' that raised inside Carbon event dispatch
(
	0   CoreFoundation                      0x00007fff82a587b4 __exceptionPreprocess + 180
	1   libobjc.A.dylib                     0x00007fff84a370f3 objc_exception_throw + 45
	2   CoreFoundation                      0x00007fff82a2a2fc -[NSArray objectsAtIndexes:] + 236
	3   Transmission                        0x000000010008c5e9 -[InfoTrackersViewController updateInfo] + 1833
	4   Transmission                        0x00000001000538c1 -[InfoWindowController updateInfoStats] + 65
	5   Transmission                        0x0000000100010e49 -[Controller updateUI] + 2249
	6   Transmission                        0x000000010001213d -[Controller updateTorrentsInQueue] + 1277
	7   Transmission                        0x000000010000dd23 -[Controller confirmRemoveTorrents:deleteData:] + 2035
	8   Transmission                        0x000000010000d406 -[Controller removeTorrents:deleteData:] + 2886
	9   Transmission                        0x000000010000ddae -[Controller removeNoDelete:] + 126
	10  AppKit                              0x00007fff86b0ae9a -[NSApplication sendAction:to:from:] + 95
	11  AppKit                              0x00007fff86b2f41e -[NSMenuItem _corePerformAction] + 365
	12  AppKit                              0x00007fff86b2f188 -[NSCarbonMenuImpl performActionWithHighlightingForItemAtIndex:] + 121
	13  AppKit                              0x00007fff86db3279 -[NSMenu _internalPerformActionForItemAtIndex:] + 35
	14  AppKit                              0x00007fff86c64f77 -[NSCarbonMenuImpl _carbonCommandProcessEvent:handlerCallRef:] + 136
	15  AppKit                              0x00007fff86b1195c NSSLMMenuEventHandler + 321
	16  HIToolbox                           0x00007fff836679d5 _ZL23DispatchEventToHandlersP14EventTargetRecP14OpaqueEventRefP14HandlerCallRec + 1002
	17  HIToolbox                           0x00007fff83666f28 _ZL30SendEventToEventTargetInternalP14OpaqueEventRefP20OpaqueEventTargetRefP14HandlerCallRec + 395
	18  HIToolbox                           0x00007fff83684beb SendEventToEventTarget + 45
	19  HIToolbox                           0x00007fff836b3d51 _ZL18SendHICommandEventjPK9HICommandjjhPKvP20OpaqueEventTargetRefS5_PP14OpaqueEventRef + 387
	20  HIToolbox                           0x00007fff836e0b86 SendMenuCommandWithContextAndModifiers + 56
	21  HIToolbox                           0x00007fff836e0b3e SendMenuItemSelectedEvent + 101
	22  HIToolbox                           0x00007fff836e0a3e _ZL19FinishMenuSelectionP13SelectionDataP10MenuResultS2_ + 150
	23  HIToolbox                           0x00007fff837e9af5 _ZL19PopUpMenuSelectCoreP8MenuData5PointdS1_tjPK4RecttjS4_S4_PK10__CFStringPP13OpaqueMenuRefPt + 1618
	24  HIToolbox                           0x00007fff837e9e4e _HandlePopUpMenuSelection7 + 665
	25  AppKit                              0x00007fff86c61f29 _NSSLMPopUpCarbonMenu3 + 3710
	26  AppKit                              0x00007fff86c622d9 -[NSCarbonMenuImpl _popUpContextMenu:withEvent:forView:withFont:] + 239
	27  AppKit                              0x00007fff86db30bc -[NSMenu _popUpContextMenu:withEvent:forView:withFont:] + 205
	28  AppKit                              0x00007fff86cb7a50 -[NSControl _rightMouseUpOrDown:] + 472
	29  AppKit                              0x00007fff86ab006f -[NSWindow sendEvent:] + 8769
	30  AppKit                              0x00007fff869e4a86 -[NSApplication sendEvent:] + 4719
	31  AppKit                              0x00007fff8697b4da -[NSApplication run] + 474
	32  AppKit                              0x00007fff869741a8 NSApplicationMain + 364
	33  Transmission                        0x0000000100001951 main + 145
	34  Transmission                        0x0000000100001894 start + 52
	35  ???                                 0x0000000000000002 0x0 + 2
)
2/25/11 11:08:22 PM	Transmission[202]	*** -[NSArray objectsAtIndexes:]: index (-1) beyond bounds (0)
2/25/11 11:08:22 PM	Transmission[202]	*** -[NSArray objectsAtIndexes:]: index (-1) beyond bounds (0)
2/25/11 11:08:34 PM	Transmission[202]	An exception was thrown during execution of an NSScriptCommand...
2/25/11 11:08:34 PM	Transmission[202]	*** -[NSArray objectsAtIndexes:]: index (-1) beyond bounds (0)
2/25/11 11:08:34 PM	Transmission[202]	*** -[NSArray objectsAtIndexes:]: index (-1) beyond bounds (0)
2/25/11 11:08:53 PM	Transmission[202]	*** -[NSArray objectsAtIndexes:]: index (-1) beyond bounds (0)
2/25/11 11:09:14 PM	Transmission[202]	*** -[NSArray objectsAtIndexes:]: index (-1) beyond bounds (0)

Client has to be restarted to clear Inspector display lockup.

Change History (6)

comment:1 Changed 7 years ago by livings124

  • Description modified (diff)

comment:2 follow-up: Changed 7 years ago by livings124

Did this happen when the transfer "demagnetized"? Were you still editing when this happened?

comment:3 in reply to: ↑ 2 Changed 7 years ago by x190

Replying to livings124:

Did this happen when the transfer "demagnetized"? Were you still editing when this happened?

Perhaps there was some unfortunate conjunction like you describe. I have been unable to reproduce the problem in 2 additional tests.

comment:4 Changed 7 years ago by x190

Perhaps this is not related to magnet links exclusively?

https://forum.transmissionbt.com/viewtopic.php?f=2&t=11394&p=53057#p53057

I have also noticed that trying to edit a pasted tracker URL fails with mouse cursor insert. The arrow keys must be used to insert the cursor in order to make a successful edit.

comment:5 Changed 7 years ago by livings124

  • Summary changed from Adding tracker prior to receiving metadata for a magnet link fails and causes Inspector lockup to Adding a tracker before last failed add causes lockup

comment:6 Changed 7 years ago by livings124

  • Milestone changed from None Set to 2.30
  • Resolution set to fixed
  • Status changed from new to closed

r12218 should fix this. Please reopen if it still occurs.

Note: See TracTickets for help on using tickets.