Opened 11 years ago

Closed 11 years ago

#4065 closed Bug (duplicate)

Build failure due to missing librt

Reported by: leena Owned by:
Priority: Normal Milestone: None Set
Component: Daemon Version: 2.20
Severity: Normal Keywords:
Cc:

Description

Building svn version: r12042 on OSX 10.6.6 using build options: ./configure --disable-gtk --disable-mac --enable-daemon --enable-cli --disable-libnotify

Configuration:

   Source code location:                              .
   Compiler:                                          g++

   Build libtransmission:                             yes

      * optimized for low-resource systems:           no
      * µTP enabled:                                  yes

   Build Command-Line client:                         yes

   Build GTK+ client:                                 no

     Optional dependencies for GTK+ client:

      * dbus support:                                 no
      * gio for watchdir support:                     no
      * libnotify for 'download completed' popups:    no
      * libcanberra for 'download completed' sounds:  no
      * gconf2 to register as a magnet link handler:  no
      * libappindicator for an Ubuntu-style tray:     no

   Build Daemon:                                      yes

   Build Mac client:                                  no

results in the following build error

...
checking for clock_gettime in -lrt... no
...
ldld: library not found for -lrt
collect2: ld returned 1 exit status
ld: library not found for -lrt
collect2: ld returned 1 exit status
: library not found for -lrt
collect2: ld returned 1 exit status
make[1]: *** [blocklist-test] Error 1
make[1]: *** Waiting for unfinished jobs....
make[1]: *** [bencode-test] Error 1
make[1]: *** [clients-test] Error 1
make: *** [all-recursive] Error 1

I thought librt was optional. It's not mentioned on the build page: https://trac.transmissionbt.com/wiki/Building

Change History (1)

comment:1 Changed 11 years ago by jordan

  • Resolution set to duplicate
  • Status changed from new to closed

This appears to have been broken by the patch for #4041 which was submitted by taem. I've reopened that ticket and asked him for an update to his patch.

Closing this ticket as a duplicate of #4041; let's continue this discussion there.

Note: See TracTickets for help on using tickets.