Opened 11 years ago

Closed 11 years ago

Last modified 11 years ago

#4069 closed Bug (duplicate)

Transmission becomes unresponsive when preallocating files or moving them from temp folder to final destination

Reported by: User294 Owned by:
Priority: Normal Milestone: None Set
Component: Transmission Version: 2.20
Severity: Normal Keywords:
Cc: keizie@…

Description

At least affects GTK+ and daemon+web UI versions.

To reproduce:

  • For preallocation:
    1) Set up T to use full preallocation
    2) Add some large torrents and take a look at UI responsibility
  • For data movement:
    1) Set up T to use temporary folder located on another disk than torrent's final destination.
    2) Download several large torrents. Place their destination on disk which is physically different from temporary folder's disk (to cause real copy + erase operation instead of just changing files paths quickly, which is possible only if source and destination located on the same disk and only paths changed during move rather than real data move occurs).
    3) Take a look what happens with UI when large torrent completes.

Result:

At least GTK+ and web ui become unresponsive while long disk operation is in progress, most notably when large files are pre-allocated or when large files are moved to different disk when download is completed.

Expected:

Those (potentially long) operations should take place in background, just as torrents verification already does.

Change History (2)

comment:1 Changed 11 years ago by jordan

  • Resolution set to duplicate
  • Status changed from new to closed

Thank you for the detailed examples; I appreciate that.

However this ticket seems to be a duplicate of #1753 so I'm going to close it. Please write any followup messages in that ticket. Thank you!

comment:2 Changed 11 years ago by keizie

  • Cc keizie@… added
Note: See TracTickets for help on using tickets.