Opened 11 years ago

Closed 11 years ago

#4092 closed Bug (worksforme)

Freezes when pausing torrents

Reported by: markthefart Owned by:
Priority: Normal Milestone: None Set
Component: Transmission Version: 2.22
Severity: Normal Keywords:
Cc:

Description

2.22 (12099) freezes when you pause a torrent 8 times out of 10 on my macbook pro (feb 2011)...

Change History (8)

comment:1 Changed 11 years ago by livings124

I can not duplicate this, on 2.22 or the nightlies. This might be better as a forum post until it can get a bit more specific.

comment:2 Changed 11 years ago by markthefart

  • Resolution set to worksforme
  • Status changed from new to closed

This issue seems to have somewhat resolved itself.

comment:3 Changed 11 years ago by polarbearted

I'm having the same problem, I have only two torrents going, and I go to pause one, and it becomes completely unresponsive. I'm running Version 2.22 on a osx 10.6.6 . It has been has been doing this since the last two updates.

comment:4 Changed 11 years ago by mschultz

Same problem here on my MacBook? Pro. Love Transmission though!

comment:5 Changed 11 years ago by rasmus

  • Resolution worksforme deleted
  • Status changed from closed to reopened
  • Summary changed from Freezes when pausing to Freezes when pausing torrents (time depending on torrent size)

I can duplicate this on several machines with both latest stable and nightly

The amount of time Transmission freezes when pausing a torrent depends on how large of a torrent it is. With smaller torrents it is barely noticeable but the time Transmission freezes increases exponentially with larger torrents.

With a 9 gigabyte torrent Transmission freezes for several minutes depending on how fast the machine is.

I've experienced this bug with all versions of Transmissions throughout its lifespan so i've decided to contribute to this ticket.

If you cannot reproduce it, make sure you're using a large enough torrent. It is barely noticeable with smaller ones.

With very large torrents (50gig+) the problem is severe forcing you to either wait a long time or force quit the application.

comment:6 follow-ups: Changed 11 years ago by x190

This is due to pre-allocation. See the following forum post for documentation.

https://forum.transmissionbt.com/viewtopic.php?f=4&t=11453#p53402

comment:7 in reply to: ↑ 6 Changed 11 years ago by rasmus

Replying to x190:

This is due to pre-allocation. See the following forum post for documentation.

https://forum.transmissionbt.com/viewtopic.php?f=4&t=11453#p53402

Ah. Thanks, i tried searching for freezing and pausing prior to creating the thread but did not see that. Changing this back to closed, sorry.

comment:8 in reply to: ↑ 6 Changed 11 years ago by rasmus

  • Resolution set to worksforme
  • Status changed from reopened to closed
  • Summary changed from Freezes when pausing torrents (time depending on torrent size) to Freezes when pausing torrents

Replying to x190:

This is due to pre-allocation. See the following forum post for documentation.

https://forum.transmissionbt.com/viewtopic.php?f=4&t=11453#p53402

Ah. Thanks, i tried searching for freezing and pausing prior to creating the thread but did not see that. Changing this back to closed, sorry.

Note: See TracTickets for help on using tickets.