Opened 11 years ago

Closed 10 years ago

#4097 closed Bug (worksforme)

Download-complete script issues incorrect TR_TORRENT_DIR

Reported by: alexmchale Owned by:
Priority: Normal Milestone: None Set
Component: Transmission Version: 2.22
Severity: Normal Keywords:
Cc:

Description

When using the option "Keep incomplete files in..." combined with "When download completes:" script, the wrong value for TR_TORRENT_DIR is passed. The "incomplete" directory is passed instead of the "completed" path where the file actually exists.

Change History (4)

comment:1 Changed 10 years ago by jordan

Is this issue still present in 2.31?

comment:2 Changed 10 years ago by toaster

I am also having this problem. I am using 2.31.

Oddly enough. I experience the following.

  1. start transmission.
  2. start two torrents.
  3. first torrent completes and I get this in the log window (info level).

2011-06-09 19:30:12 -0700 torrent.c:1909 [Info] FILENAME.of.torrent.txt: Calling script "/path/to/my/script.sh" 2011-06-09 19:30:12 -0700 torrent.c:2833 [Info] FILENAME.of.torrent.txt: moving "/path/of/working/dir/FILENAME.of.torrent.txt" to "/path/of/completed/dir/FILENAME.of.torrent.txt"

This results in the file downloaded ending up in the completed dir, but the script failing to run properly (file is not moved by the script).

  1. When the second download completes, this shows in the log.

2011-06-09 19:33:26 -0700 torrent.c:2833 [Info] ANOTHER_FILENAME.of.torrent.txt: moving "/path/to/working/dir/ANOTHER_FILENAME.of.torrent.txt" to "/path/to/completed/dir/ANOTHER_FILENAME.of.torrent.txt" 2011-06-09 19:33:26 -0700 torrent.c:1909 [Info] ANOTHER_FILENAME.of.torrent.txt: Calling script "/path/to/my/script.sh"

Note that the order is reversed for this second log (for the second torrent completed). In this case, the script does indeed move the file out of the completed directory into where I specify inside my script.sh script.

comment:3 Changed 10 years ago by livings124

Is this still an issue? I have been unable to reproduce this.

comment:4 Changed 10 years ago by jordan

  • Resolution set to worksforme
  • Status changed from new to closed

Please reopen this ticket after answering the questions above. Thank you!

Note: See TracTickets for help on using tickets.