Opened 11 years ago

Closed 11 years ago

#4098 closed Bug (worksforme)

Downloads to wrong location after "Not enough free space" error

Reported by: MrBerns Owned by: livings124
Priority: Normal Milestone: None Set
Component: Mac Client Version: 2.22
Severity: Normal Keywords:
Cc:

Description

I have rules set up to automatically apply a group to incoming torrents based upon tracker information which changes the download location for the torrents. This works fine, unless I receive the "Not enough free space" error. In that case, it tries to download the files to the default location rather than the group-specific location where it should download. There are often .part files in the correct location, as if Transmission initially downloaded to the correct location, but then changed the location after the error.

Change History (5)

comment:1 Changed 11 years ago by jordan

  • Component changed from Transmission to Mac Client
  • Owner set to livings124

comment:2 Changed 11 years ago by livings124

Are you sure the alert is related? The alert is just a window that pops up - it doesn't have any behavior changes. Do you have an incomplete directory set?

comment:3 Changed 11 years ago by MrBerns

I don't have an incomplete directory, but I do have it set to append .part to incomplete files. Typically once I get that message, I either pause the download or close Transmission completely until I have cleared enough space for the download. It might be that when the message itself occurs, the download is going to the right place, but after the download is paused/closed and then resumed, it tries to download to the incorrect (default) location.

comment:4 Changed 11 years ago by livings124

So you get the error, pause the torrent, and then when you restart it it goes to the wrong location?

Are you out of hard drive space when this error occurs, or is it the "you will run out of space if you download" warning?

Last edited 11 years ago by livings124 (previous) (diff)

comment:5 Changed 11 years ago by livings124

  • Resolution set to worksforme
  • Status changed from new to closed

Without more information, there's nothing I can do. My guess is you're out of space, causing weird issues with saving changed settings. Please reopen with more info.

Note: See TracTickets for help on using tickets.