Opened 11 years ago

Closed 10 years ago

Last modified 10 years ago

#4101 closed Bug (fixed)

RPC method blocklist-update is broken

Reported by: bb Owned by:
Priority: Normal Milestone: 2.32
Component: Mac Client Version: 2.22
Severity: Normal Keywords:
Cc:

Description

blocklist-update always returns blocklist-size: 0

Updating the blocklist using the GUI (Mac OS X Client works like aspected)

Attachments (4)

session_gui.txt (3.9 KB) - added by bb 11 years ago.
transmission-remote -b -si output after clicking on the update blocklist button
blocklist_update.txt (1.9 KB) - added by bb 11 years ago.
transmission-remote -b --blocklist-update output
session_rpc.txt (3.9 KB) - added by bb 11 years ago.
transmission-remote -b -si output after transmission-remote --blocklist-update
osx_ui_bug.png (73.3 KB) - added by bb 10 years ago.
Screenhost of the error in the OS X GUI

Download all attachments as: .zip

Change History (47)

Changed 11 years ago by bb

transmission-remote -b -si output after clicking on the update blocklist button

Changed 11 years ago by bb

transmission-remote -b --blocklist-update output

Changed 11 years ago by bb

transmission-remote -b -si output after transmission-remote --blocklist-update

comment:1 Changed 10 years ago by jordan

I'm not able to reproduce this issue in 2.30 beta 4.

Are you still seeing this problem?

If so, what is the URL of the blocklist that you're using?

comment:2 Changed 10 years ago by bb

I am using http://www.bluetack.co.uk/config/level1.gz

The old transmission-daemon (12099) works fine with this url.

But the beta still fails

comment:3 Changed 10 years ago by jordan

Here's what I get with 2.30 beta 4 with that blocklist URL:

{"arguments":{"blocklist-size":220140},"result":"success"}

comment:4 Changed 10 years ago by jordan

Are you using the Mac binary distributed on transmissionbt.com?

comment:5 Changed 10 years ago by bb

Yes, sorry I wasn't able to get online the last days.

comment:6 Changed 10 years ago by livings124

  • Resolution set to invalid
  • Status changed from new to closed

The issue seems to be on the blocklist site, with them blocking the client from downloading the list.

comment:7 Changed 10 years ago by bb

  • Resolution invalid deleted
  • Status changed from closed to reopened
  • Version changed from 2.22 to 2.31

Hi, I tested it again.

Updating through the GUI (OS X 2.31) works fine, but updating with the RPC call doesn't work.

It always returns {"arguments":{"blocklist-size":0},"result":"success"}.

comment:8 Changed 10 years ago by livings124

  • Version changed from 2.31 to 2.21

comment:9 Changed 10 years ago by jordan

Do you have any more information about how to reproduce this error? Testing 2.31 with the blocklist you listed, I get this:

$ ./transmission-remote host:9099 --debug --blocklist-update
posting:
--------
{"method":"blocklist-update"}

--------
* Couldn't find host host in the .netrc file; using defaults
* About to connect() to host port 9099 (#0)
*   Trying 192.168.1.99... * connected
* Connected to host (192.168.1.99) port 9099 (#0)
> POST /transmission/rpc/ HTTP/1.1
User-Agent: transmission-remote/2.31+ (12472)
Host: host:9099
Accept: */*
Accept-Encoding: deflate, gzip
Content-Length: 30
Content-Type: application/x-www-form-urlencoded

< HTTP/1.1 409 Conflict
< Server: Transmission
< X-Transmission-Session-Id: Ok3pY1P194PT4GVWTbupCdFy7seArobzO4LeObC8UnaUXeMD
< Date: Mon, 30 May 2011 14:29:10 GMT
< Content-Length: 580
< Content-Type: text/html; charset=ISO-8859-1
< 
* Connection #0 to host host left intact
* Closing connection #0
posting:
--------
{"method":"blocklist-update"}

--------
* Couldn't find host host in the .netrc file; using defaults
* About to connect() to host port 9099 (#0)
*   Trying 192.168.1.99... * connected
* Connected to host (192.168.1.99) port 9099 (#0)
> POST /transmission/rpc/ HTTP/1.1
User-Agent: transmission-remote/2.31+ (12472)
Host: host:9099
Accept: */*
Accept-Encoding: deflate, gzip
X-Transmission-Session-Id: Ok3pY1P194PT4GVWTbupCdFy7seArobzO4LeObC8UnaUXeMD
Content-Length: 30
Content-Type: application/x-www-form-urlencoded

< HTTP/1.1 200 OK
< Server: Transmission
< Content-Encoding: gzip
< Content-Type: application/json; charset=UTF-8
< Date: Mon, 30 May 2011 14:29:27 GMT
< Content-Length: 79
< 
* Connection #0 to host host left intact
got response (len 59):
--------
{"arguments":{"blocklist-size":220226},"result":"success"}

--------
http://host:9099/transmission/rpc/ responded: "success"
* Closing connection #0
Last edited 10 years ago by jordan (previous) (diff)

comment:10 Changed 10 years ago by bb

I always get this:

./transmission-remote localhost:9091 --debug --blocklist-update
posting:
--------
{"method":"blocklist-update"}

--------
* Couldn't find host localhost in the .netrc file; using defaults
* About to connect() to localhost port 9091 (#0)
*   Trying ::1... * Connection refused
*   Trying fe80::1... * Connection refused
*   Trying 127.0.0.1... * connected
* Connected to localhost (127.0.0.1) port 9091 (#0)
> POST /transmission/rpc/ HTTP/1.1
User-Agent: transmission-remote/2.31+ (12474)
Host: localhost:9091
Accept: */*
Accept-Encoding: deflate, gzip
Content-Length: 30
Content-Type: application/x-www-form-urlencoded

< HTTP/1.1 409 Conflict
< Server: Transmission
< X-Transmission-Session-Id: 1FOT1gogxF2SmKTCNfcpG2u1UBkIdtz70AGjedu60Xlpg7nh
< Date: Mon, 30 May 2011 14:50:18 GMT
< Content-Length: 580
< Content-Type: text/html; charset=ISO-8859-1
< 
* Connection #0 to host localhost left intact
* Closing connection #0
posting:
--------
{"method":"blocklist-update"}

--------
* Couldn't find host localhost in the .netrc file; using defaults
* About to connect() to localhost port 9091 (#0)
*   Trying ::1... * Connection refused
*   Trying fe80::1... * Connection refused
*   Trying 127.0.0.1... * connected
* Connected to localhost (127.0.0.1) port 9091 (#0)
> POST /transmission/rpc/ HTTP/1.1
User-Agent: transmission-remote/2.31+ (12474)
Host: localhost:9091
Accept: */*
Accept-Encoding: deflate, gzip
X-Transmission-Session-Id: 1FOT1gogxF2SmKTCNfcpG2u1UBkIdtz70AGjedu60Xlpg7nh
Content-Length: 30
Content-Type: application/x-www-form-urlencoded

< HTTP/1.1 200 OK
< Server: Transmission
< Content-Type: application/json; charset=UTF-8
< Date: Mon, 30 May 2011 14:50:35 GMT
< Content-Length: 54
< 
* Connection #0 to host localhost left intact
got response (len 54):
--------
{"arguments":{"blocklist-size":0},"result":"success"}

--------
http://localhost:9091/transmission/rpc/ responded: "success"
* Closing connection #0

When I use the UI it works fine .

comment:11 Changed 10 years ago by jordan

  • Component changed from Transmission to Mac Client

Looks like the Mac client isn't being compiled with libz support

comment:12 Changed 10 years ago by livings124

  • Version changed from 2.21 to 2.22

comment:13 Changed 10 years ago by livings124

Can you try r12484 and report back?

comment:14 Changed 10 years ago by bb

Hi now I am getting this error:

./transmission-remote localhost:9091 --debug --blocklist-update
posting:
--------
{"method":"blocklist-update"}

--------
* Couldn't find host localhost in the .netrc file; using defaults
* About to connect() to localhost port 9091 (#0)
*   Trying ::1... * Connection refused
*   Trying fe80::1... * Connection refused
*   Trying 127.0.0.1... * connected
* Connected to localhost (127.0.0.1) port 9091 (#0)
> POST /transmission/rpc/ HTTP/1.1
User-Agent: transmission-remote/2.31+ (12474)
Host: localhost:9091
Accept: */*
Accept-Encoding: deflate, gzip
Content-Length: 30
Content-Type: application/x-www-form-urlencoded

< HTTP/1.1 409 Conflict
< Server: Transmission
< X-Transmission-Session-Id: t66Lr7G4shcUcK9G9zetSo7s0ms7PNQ9Twf5zOjCfvq5z4kM
< Date: Tue, 31 May 2011 23:24:40 GMT
< Content-Length: 580
< Content-Type: text/html; charset=ISO-8859-1
< 
* Connection #0 to host localhost left intact
* Closing connection #0
posting:
--------
{"method":"blocklist-update"}

--------
* Couldn't find host localhost in the .netrc file; using defaults
* About to connect() to localhost port 9091 (#0)
*   Trying ::1... * Connection refused
*   Trying fe80::1... * Connection refused
*   Trying 127.0.0.1... * connected
* Connected to localhost (127.0.0.1) port 9091 (#0)
> POST /transmission/rpc/ HTTP/1.1
User-Agent: transmission-remote/2.31+ (12474)
Host: localhost:9091
Accept: */*
Accept-Encoding: deflate, gzip
X-Transmission-Session-Id: t66Lr7G4shcUcK9G9zetSo7s0ms7PNQ9Twf5zOjCfvq5z4kM
Content-Length: 30
Content-Type: application/x-www-form-urlencoded

< HTTP/1.1 200 OK
< Server: Transmission
< Content-Encoding: gzip
< Content-Type: application/json; charset=UTF-8
< Date: Tue, 31 May 2011 23:24:56 GMT
< Content-Length: 52
< 
* Connection #0 to host localhost left intact
got response (len 32):
--------
{"arguments":{},"result":""}

--------
[01:24:56.806] JSON parser failed at line 1, column 27: ""}
?w?"
[01:24:56.806] transmission-remote: Unable to parse response "{"arguments":{},"result":""}
"
* Closing connection #0

comment:15 Changed 10 years ago by livings124

Make sure to do a clean build of r12486

comment:16 Changed 10 years ago by bb

Other error:

./transmission-remote localhost:9091 --debug --blocklist-update
posting:
--------
{"method":"blocklist-update"}

--------
* Couldn't find host localhost in the .netrc file; using defaults
* About to connect() to localhost port 9091 (#0)
*   Trying ::1... * Connection refused
*   Trying fe80::1... * Connection refused
*   Trying 127.0.0.1... * connected
* Connected to localhost (127.0.0.1) port 9091 (#0)
> POST /transmission/rpc/ HTTP/1.1
User-Agent: transmission-remote/2.31+ (12474)
Host: localhost:9091
Accept: */*
Accept-Encoding: deflate, gzip
Content-Length: 30
Content-Type: application/x-www-form-urlencoded

< HTTP/1.1 409 Conflict
< Server: Transmission
< X-Transmission-Session-Id: yRV8GyyzFBcHSbo6upjCSLLRHgh4g7EpGTas2Q3wlQS7cZ0e
< Date: Tue, 31 May 2011 23:34:48 GMT
< Content-Length: 580
< Content-Type: text/html; charset=ISO-8859-1
< 
* Connection #0 to host localhost left intact
* Closing connection #0
posting:
--------
{"method":"blocklist-update"}

--------
* Couldn't find host localhost in the .netrc file; using defaults
* About to connect() to localhost port 9091 (#0)
*   Trying ::1... * Connection refused
*   Trying fe80::1... * Connection refused
*   Trying 127.0.0.1... * connected
* Connected to localhost (127.0.0.1) port 9091 (#0)
> POST /transmission/rpc/ HTTP/1.1
User-Agent: transmission-remote/2.31+ (12474)
Host: localhost:9091
Accept: */*
Accept-Encoding: deflate, gzip
X-Transmission-Session-Id: yRV8GyyzFBcHSbo6upjCSLLRHgh4g7EpGTas2Q3wlQS7cZ0e
Content-Length: 30
Content-Type: application/x-www-form-urlencoded

< HTTP/1.1 200 OK
< Server: Transmission
< Content-Encoding: gzip
< Content-Type: application/json; charset=UTF-8
< Date: Tue, 31 May 2011 23:35:03 GMT
< Content-Length: 53
< 
* Connection #0 to host localhost left intact
got response (len 33):
--------
{"arguments":{},"result":"`"}

--------
[01:35:03.747] JSON parser failed at line 1, column 28: ""}
w?"
[01:35:03.747] transmission-remote: Unable to parse response "{"arguments":{},"result":"`"}
"
* Closing connection #0

comment:17 Changed 10 years ago by livings124

Can you run Transmission.app from a terminal with TR_CURL_VERBOSE set in the environment so that we can see what libtransmission and the blocklist site are saying to each other?

comment:18 Changed 10 years ago by bb

Yes, here is the log:

* About to connect() to rps8755.ovh.net port 80 (#0)
*   Trying 94.23.197.115... * Connected to rps8755.ovh.net (94.23.197.115) port 80 (#0)
> GET /blocklists/level1.gz HTTP/1.1

User-Agent: Transmission/2.31+

Host: rps8755.ovh.net

Accept: */*

Accept-Encoding: gzip;q=1.0, deflate, identity



< HTTP/1.1 200 OK

< Server: nginx

< Date: Tue, 07 Jun 2011 06:53:36 GMT

< Content-Type: application/octet-stream

< Content-Length: 3756364

< Last-Modified: Mon, 06 Jun 2011 04:58:12 GMT

< Connection: keep-alive

< Keep-Alive: timeout=10

< Expires: Wed, 08 Jun 2011 06:53:36 GMT

< Cache-Control: max-age=86400

< Accept-Ranges: bytes

< 

* Expire cleared
* Connection #0 to host rps8755.ovh.net left intact

comment:19 follow-up: Changed 10 years ago by jordan

Hmmm.

Well, it looks like the .gz file was probably fetched successfully, and that the problem is probably in the decompression code in libtransmission when compiled on Mac OS X.

I'll add some debug statements to the decompression code later today. After I do that, let's repeat the test and also look for the debug messages...

comment:20 in reply to: ↑ 19 Changed 10 years ago by bb

Replying to jordan:

Hmmm.

Well, it looks like the .gz file was probably fetched successfully, and that the problem is probably in the decompression code in libtransmission when compiled on Mac OS X.

I'll add some debug statements to the decompression code later today. After I do that, let's repeat the test and also look for the debug messages...

OK, just let me know if I should do further testing. BTW: Updating over the GUI still works fine

comment:21 Changed 10 years ago by jordan

Sorry it took a couple of days to get back to this, but this is finally in r12494. You'll want to look for errors in the message log after the download (or uncompression) fails.

comment:22 Changed 10 years ago by livings124

Hey bb, have you had a chance to run the new build?

comment:23 Changed 10 years ago by bb

Sorry I was also off for some days.

Here the output of the latest version:

 TR_CURL_VERBOSE=1 Transmission.app/Contents/MacOS/Transmission 
* About to connect() to rps8755.ovh.net port 80 (#0)
*   Trying 94.23.197.115... * Connected to rps8755.ovh.net (94.23.197.115) port 80 (#0)
> GET /blocklists/level1.gz HTTP/1.1
User-Agent: Transmission/2.31+
Host: rps8755.ovh.net
Accept: */*
Accept-Encoding: gzip;q=1.0, deflate, identity

< HTTP/1.1 200 OK
< Server: nginx
< Date: Thu, 16 Jun 2011 06:07:43 GMT
< Content-Type: application/octet-stream
< Content-Length: 3756339
< Last-Modified: Wed, 15 Jun 2011 22:11:05 GMT
< Connection: keep-alive
< Keep-Alive: timeout=10
< Expires: Fri, 17 Jun 2011 06:07:43 GMT
< Cache-Control: max-age=86400
< Accept-Ranges: bytes
< 
* Expire cleared
* Connection #0 to host rps8755.ovh.net left intact









./transmission-remote localhost:9091 --debug --blocklist-update
posting:
--------
{"method":"blocklist-update"}

--------
* Couldn't find host localhost in the .netrc file; using defaults
* About to connect() to localhost port 9091 (#0)
*   Trying ::1... * Connection refused
*   Trying fe80::1... * Connection refused
*   Trying 127.0.0.1... * connected
* Connected to localhost (127.0.0.1) port 9091 (#0)
> POST /transmission/rpc/ HTTP/1.1
User-Agent: transmission-remote/2.31+ (12474)
Host: localhost:9091
Accept: */*
Accept-Encoding: deflate, gzip
Content-Length: 30
Content-Type: application/x-www-form-urlencoded

< HTTP/1.1 409 Conflict
< Server: Transmission
< X-Transmission-Session-Id: Ot9182MvtSBsFjLyowTrYeSj1uaa5AMfhQ0EK52uI3ZZPjem
< Date: Thu, 16 Jun 2011 06:07:44 GMT
< Content-Length: 580
< Content-Type: text/html; charset=ISO-8859-1
< 
* Connection #0 to host localhost left intact
* Closing connection #0
posting:
--------
{"method":"blocklist-update"}

--------
* Couldn't find host localhost in the .netrc file; using defaults
* About to connect() to localhost port 9091 (#0)
*   Trying ::1... * Connection refused
*   Trying fe80::1... * Connection refused
*   Trying 127.0.0.1... * connected
* Connected to localhost (127.0.0.1) port 9091 (#0)
> POST /transmission/rpc/ HTTP/1.1
User-Agent: transmission-remote/2.31+ (12474)
Host: localhost:9091
Accept: */*
Accept-Encoding: deflate, gzip
X-Transmission-Session-Id: Ot9182MvtSBsFjLyowTrYeSj1uaa5AMfhQ0EK52uI3ZZPjem
Content-Length: 30
Content-Type: application/x-www-form-urlencoded

< HTTP/1.1 200 OK
< Server: Transmission
< Content-Encoding: gzip
< Content-Type: application/json; charset=UTF-8
< Date: Thu, 16 Jun 2011 06:07:59 GMT
< Content-Length: 49
< 
* Connection #0 to host localhost left intact
got response (len 29):
--------
{"arguments":{},"result":""}

--------
http://localhost:9091/transmission/rpc/ responded: ""
* Closing connection #0

comment:24 Changed 10 years ago by jordan

You'll want to look for errors in the message log after the download (or uncompression) fails though...

comment:25 follow-up: Changed 10 years ago by bb

Hi, the nightly doesn't report any error, but the stable does.

2011-06-16 20:13:35 +0200 blocklist.c:368 [Fehler] Transmission: blocklist skipped invalid address at line 15014
2011-06-16 20:13:35 +0200 blocklist.c:368 [Fehler] Transmission: blocklist skipped invalid address at line 15015
2011-06-16 20:13:35 +0200 blocklist.c:368 [Fehler] Transmission: blocklist skipped invalid address at line 15016
2011-06-16 20:13:35 +0200 blocklist.c:368 [Fehler] Transmission: blocklist skipped invalid address at line 15017
2011-06-16 20:13:35 +0200 blocklist.c:368 [Fehler] Transmission: blocklist skipped invalid address at line 15018
2011-06-16 20:13:35 +0200 blocklist.c:368 [Fehler] Transmission: blocklist skipped invalid address at line 15019
2011-06-16 20:13:35 +0200 blocklist.c:368 [Fehler] Transmission: blocklist skipped invalid address at line 15020
2011-06-16 20:13:35 +0200 blocklist.c:368 [Fehler] Transmission: blocklist skipped invalid address at line 15021
2011-06-16 20:13:35 +0200 blocklist.c:368 [Fehler] Transmission: blocklist skipped invalid address at line 15022
2011-06-16 20:13:35 +0200 blocklist.c:368 [Fehler] Transmission: blocklist skipped invalid address at line 15023
2011-06-16 20:13:35 +0200 blocklist.c:368 [Fehler] Transmission: blocklist skipped invalid address at line 15024
2011-06-16 20:13:35 +0200 blocklist.c:368 [Fehler] Transmission: blocklist skipped invalid address at line 15025
2011-06-16 20:13:35 +0200 blocklist.c:368 [Fehler] Transmission: blocklist skipped invalid address at line 15026
2011-06-16 20:13:35 +0200 blocklist.c:368 [Fehler] Transmission: blocklist skipped invalid address at line 15027
2011-06-16 20:13:35 +0200 blocklist.c:368 [Fehler] Transmission: blocklist skipped invalid address at line 15028
2011-06-16 20:13:35 +0200 blocklist.c:368 [Fehler] Transmission: blocklist skipped invalid address at line 15029
2011-06-16 20:13:35 +0200 blocklist.c:368 [Fehler] Transmission: blocklist skipped invalid address at line 15030
2011-06-16 20:13:35 +0200 blocklist.c:368 [Fehler] Transmission: blocklist skipped invalid address at line 15031
2011-06-16 20:13:35 +0200 blocklist.c:368 [Fehler] Transmission: blocklist skipped invalid address at line 15032
2011-06-16 20:13:35 +0200 blocklist.c:368 [Fehler] Transmission: blocklist skipped invalid address at line 15033
2011-06-16 20:13:35 +0200 blocklist.c:420 [Informationen] Transmission: Blocklist "blocklist.bin" updated with 0 entries
2011-06-16 20:13:35 +0200 blocklist.c:115 [Informationen] Transmission: Blocklist "blocklist.bin" contains 0 entries

comment:26 Changed 10 years ago by x190

Built 12502 using xcodproj on Mac Intel 10.6.7 to test.

Will not update blocklist via transmission-remote even tho' --session-info shows it knows the blocklist url. Judging by the time delay it seems? that the .gz is being downloaded, however, no blocklist.bin is produced and 0 messages appear in log. Update via Mac Client->Preferences works.

{"arguments":{"blocklist-enabled":true,"blocklist-size":0,"blocklist-url":"http://www.bluetack.co.uk/config/level1.gz","cache-size-mb":4

Does Transmission store the blocklist.gz file somewhere before calling decompression code?

comment:27 in reply to: ↑ 25 Changed 10 years ago by x190

Replying to bb:

Hi, the nightly doesn't report any error, but the stable does.

2011-06-16 20:13:35 +0200 blocklist.c:368 [Fehler] Transmission: blocklist skipped invalid address at line 15033
2011-06-16 20:13:35 +0200 blocklist.c:420 [Informationen] Transmission: Blocklist "blocklist.bin" updated with 0 entries
2011-06-16 20:13:35 +0200 blocklist.c:115 [Informationen] Transmission: Blocklist "blocklist.bin" contains 0 entries}}}

Getting this exact same log message using my newly built transmission-remote (12502) and my older hacked 2.21+. This one does produce a blocklist.bin of 0 size [EDIT: This would indicate the application is reading a file with a known line count but without the address ranges filled in.] unlike the nightly (12502) which produces neither blocklist.bin nor any log entries [EDIT: No file read.].

Last edited 10 years ago by x190 (previous) (diff)

comment:28 Changed 10 years ago by x190

Hmmm... Works sometimes with iblocklist (P2P-a biggie-2.4 MB bin size).

* Connection #0 to host localhost left intact
got response (len 59):
--------
{"arguments":{"blocklist-size":295679},"result":"success"}

remote from 12502 with 2.21+ works with iblocklist P2P

Summary: Works every time in client interface for bluetack and iblocklist, only for iblocklist in transmission-remote and then not every time. Other apps such as Firefox and PG2 exhibit similar behavior depending upon the exact url.

Using transmission-remote (12505) Xcode build:

http://download.m0k.org/transmission/files/level1 (works) http://download.m0k.org/transmission/files/level1.gz (fails with 0 size) http://list.iblocklist.com/?list=ijfqtofzixtwayqovmxn.gz (works about 80%)

bb: If you really need to update bluetack level 1 via transmission-remote try using iblocklist's url for level1. The following works for me and is also bluetack. http://list.iblocklist.com/?list=bt_level1&fileformat=p2p&archiveformat=gz

[EDIT: The above "download.m0k.org" urls are now defunct. Please visit iblocklist's site for updated urls.]

P.S. transmission-remote (r12505) causes T's real memory usage to increase by 2 - 2.5.

Last edited 10 years ago by x190 (previous) (diff)

comment:29 Changed 10 years ago by jordan

bb, are there any log messages about uncompression coming from rpcimpl.c?

comment:30 follow-up: Changed 10 years ago by bb

x190: thx for the info

jordan: No, I don't see any messages about this.

Does the OS X Version stores the log on the disk? It seems the log is cut because of great number of log entries.

comment:31 Changed 10 years ago by x190

0
2011-06-16 20:13:35 +0200 blocklist.c:368 [Fehler] Transmission: blocklist skipped invalid address at line 15031
2011-06-16 20:13:35 +0200 blocklist.c:368 [Fehler] Transmission: blocklist skipped invalid address at line 15032
2011-06-16 20:13:35 +0200 blocklist.c:368 [Fehler] Transmission: blocklist skipped invalid address at line 15033

This (15033) is the line count of the .gz file. The uncompressed file should have over 225000 lines. It is normal to get this error message for blank or unparseable lines so it seems gzread is returning 15033 empty or mangled or uncompressed lines.

Last edited 10 years ago by x190 (previous) (diff)

comment:32 in reply to: ↑ 30 Changed 10 years ago by x190

Replying to bb:

x190: thx for the info

You're welcome! :)

Replying to bb:

Does the OS X Version stores the log on the disk? It seems the log is cut because of great number of log entries.

Comment out line 368 in blocklist.c to avoid spamming your Message Log and build in Xcode. There is no log on disk.

/* don't try to display the actual lines - it causes issues 
            tr_err( _( "blocklist skipped invalid address at line %d" ), inCount );*/

Last edited 10 years ago by x190 (previous) (diff)

comment:33 Changed 10 years ago by jordan

Does r12521 change anything, for better or worse? :)

comment:34 Changed 10 years ago by bb

Hi, seems to be a lot better :)

 ./transmission-remote localhost:9091 --debug --blocklist-update
posting:
--------
{"method":"blocklist-update"}

--------
* Couldn't find host localhost in the .netrc file; using defaults
* About to connect() to localhost port 9091 (#0)
*   Trying 127.0.0.1... * connected
* Connected to localhost (127.0.0.1) port 9091 (#0)
> POST /transmission/rpc/ HTTP/1.1
User-Agent: transmission-remote/2.31+ (12474)
Host: localhost:9091
Accept: */*
Accept-Encoding: deflate, gzip
Content-Length: 30
Content-Type: application/x-www-form-urlencoded

< HTTP/1.1 409 Conflict
< Server: Transmission
< X-Transmission-Session-Id: SsLFZ0dAiJADmipI8J6JJHsSrCmnxSYV4He02sRYRFjJQ1fD
< Date: Sun, 26 Jun 2011 17:17:10 GMT
< Content-Length: 580
< Content-Type: text/html; charset=ISO-8859-1
< 
* Connection #0 to host localhost left intact
* Closing connection #0
posting:
--------
{"method":"blocklist-update"}

--------
* Couldn't find host localhost in the .netrc file; using defaults
* About to connect() to localhost port 9091 (#0)
*   Trying 127.0.0.1... * connected
* Connected to localhost (127.0.0.1) port 9091 (#0)
> POST /transmission/rpc/ HTTP/1.1
User-Agent: transmission-remote/2.31+ (12474)
Host: localhost:9091
Accept: */*
Accept-Encoding: deflate, gzip
X-Transmission-Session-Id: SsLFZ0dAiJADmipI8J6JJHsSrCmnxSYV4He02sRYRFjJQ1fD
Content-Length: 30
Content-Type: application/x-www-form-urlencoded

< HTTP/1.1 200 OK
< Server: Transmission
< Content-Encoding: gzip
< Content-Type: application/json; charset=UTF-8
< Date: Sun, 26 Jun 2011 17:17:22 GMT
< Content-Length: 79
< 
* Connection #0 to host localhost left intact
got response (len 59):
--------
{"arguments":{"blocklist-size":220267},"result":"success"}

--------
http://localhost:9091/transmission/rpc/ responded: "success"
* Closing connection #0
bbmbp:bin bb$ 

Tested http://list.iblocklist.com/?list=bt_level1&fileformat=p2p&archiveformat=gz

comment:35 follow-up: Changed 10 years ago by jordan

  • Milestone changed from None Set to 2.32
  • Resolution set to fixed
  • Status changed from reopened to closed

Sounds good. Closing as fixed.

If there are any further issues, please reopen the ticket. Thanks!

comment:36 in reply to: ↑ 35 Changed 10 years ago by x190

Replying to jordan:

Sounds good. Closing as fixed.

If there are any further issues, please reopen the ticket. Thanks!

Thanks for the heroic effort! :) Maybe should be reported upstream? Seems to be a bluetack from bluetack plus Mac issue. Anyhow, thankfully, iblocklist does and did get the job done. Frustrations!!! Would have loved to have found the solution to this one. :(

#include <stdio.h>

int main()
{
    printf( "kkk\rkkk\n" );
}
$$ gcc -o pfk /Users/sl/Desktop/pfk.txt.c 
J-Bs-iMac:Desktop sl$ ./pfk
kkk 

Pesky '\r's cause printf to output blanks just like our infamous blanklined blocklist. Fap!

Somebody or something needs to change CRs (\r) in the data stream to LFs .

"Incorrectly assuming a new-line character is read by fgets() or fgetws() can result in data truncation."

Last edited 10 years ago by x190 (previous) (diff)

comment:37 Changed 10 years ago by x190

Jordan: I guess you didn't realize it, but this issue was never fixed for bluetack lists on OS X. If you look closely at comment:34, bb was testing with iblocklist which always did work (most of the time) even with the original code. Neither of us had the heart to tell you at the time. Although OS X and Unix should handle CRLFs the same way, OS X plus bluetack(gz) from bluetack.co.uk, just will not work using either form of your code. I wonder if we could pass the file through some code to get rid the CRLFs and replace them with LFs (\n) only? Please see the following:

http://www.gzip.org/fixgz.c

OS X 10.6.8 uses #define ZLIB_VERSION "1.2.3"

In addition, why does iblocklist fail about 1 out of 5 times when they don't use "\r\n"? Bluetack lists from bluetack.co.uk fail 100% of the time on OS X and does use "\r\n".

Last edited 10 years ago by x190 (previous) (diff)

comment:38 follow-up: Changed 10 years ago by bb

Just drop a line if you need further testing.

comment:39 in reply to: ↑ 38 Changed 10 years ago by x190

Replying to bb:

Just drop a line if you need further testing.

Hi bb: Could you please retest using the troublesome URL, namely:

http://www.bluetack.co.uk/config/level1.gz

If your results are still negative, I guess this ticket should be re-opened.

Changed 10 years ago by bb

Screenhost of the error in the OS X GUI

comment:40 follow-up: Changed 10 years ago by bb

With Transmission 2.33, updating the blacklist using RPC works fine. The OS X GUI still seems to be broken.

comment:41 in reply to: ↑ 40 Changed 10 years ago by x190

Replying to bb:

With Transmission 2.33, updating the blacklist using RPC works fine. The OS X GUI still seems to be broken.

That's odd as it was the reverse situation originally. Just to confirm, are you testing with http://www.bluetack.co.uk/config/level1.gz?

Are you using Snow Leopard 10.6.8 or Lion 10.7.1? Please do man zlib in Terminal.app and hit spacebar until you find the version number and then post your zlib version. Thanks!

comment:42 Changed 10 years ago by bb

I am using Lion 10.7.1. zlib version: 1.2.5

This time the GUI worked :O, maybe an invisible HTML char in the textfield.

comment:43 Changed 10 years ago by x190

I suspect that if that URL (http://www.bluetack.co.uk/config/level1.gz) now works consistently in transmission-remote, it is due to the updated zlib library. Thanks for testing bb. :-)

Note: See TracTickets for help on using tickets.