Opened 11 years ago

Closed 10 years ago

#4103 closed Bug (invalid)

download-dir stored and used upon torrent add NOT torrent complete

Reported by: oh_noes Owned by:
Priority: Normal Milestone: None Set
Component: Transmission Version: 2.22
Severity: Normal Keywords: download-dir
Cc:

Description

  1. Set download-dir to /foo.
  2. Download a torrent
  3. Stop transmission-daemon before torrent finishes
  4. Change download-dir to /bar.
  5. Start transmission
  6. Let torrent finish.

End result, torrent is moved to /foo, not /bar.

This is asking for trouble. In some case the mount might not be there, disk is full, etc.

I don't think this is expected behavior. Please change so that when a torrent completes, it uses the "current" download-dir.

Change History (1)

comment:1 Changed 10 years ago by jordan

  • Resolution set to invalid
  • Status changed from new to closed

This is by design. Torrents pick up their download-dir setting from Preferences when they're added.

Think of it this way, what happens if the incomplete dir is changed while a torrent's downloading? Or, if the incomplete dir is toggled while a torrent's downloading? Or if the incomplete dir is disabled, and the download-dir is changed while downloading? All of these actions would lead to problems. That's why incomplete & download dir are applied when the torrent is created.

Note: See TracTickets for help on using tickets.